summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-25 20:30:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-26 05:39:07 +0200
commitf861d7c1408bbabc6ee19f4ca584758f8b390de8 (patch)
treebf031511f3c9aaedda46fd524b38de406ac74fd3
parentdev-util/pycharm-community: remove old version (diff)
downloadgentoo-f861d7c1.tar.gz
gentoo-f861d7c1.tar.bz2
gentoo-f861d7c1.zip
www-servers/pshs: Bump to 0.4.2
Closes: https://bugs.gentoo.org/906973 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--www-servers/pshs/Manifest1
-rw-r--r--www-servers/pshs/metadata.xml4
-rw-r--r--www-servers/pshs/pshs-0.4.2.ebuild42
3 files changed, 45 insertions, 2 deletions
diff --git a/www-servers/pshs/Manifest b/www-servers/pshs/Manifest
index d7b0b1140eab..c2a944a38aa7 100644
--- a/www-servers/pshs/Manifest
+++ b/www-servers/pshs/Manifest
@@ -1 +1,2 @@
DIST pshs-0.4.1.tar.gz 11758 BLAKE2B b3f9422c8ebd47d3de9993b93ea0438232f3ba037d7433b08875a131f449fab880a205bb62616a057328b7d6fe9c00277fbb2e886a1494d2234ab684b0a1e90f SHA512 7ecd0e5019e9778b5f2eff31b8e2f481972cf6da66e4493cff850aa1ec13a4df46e46782799ab25cecd1cc36122f797c6ae0ac2863ea604477784a79191a62d6
+DIST pshs-0.4.2.gh.tar.gz 11908 BLAKE2B 34afa32fe8cdb9212bcc22ec8b33e149b703cb2c5d12d4655732ce6e1400850a42770f2a5855c826bbcc1fb31e6f891a7e06fbf34bc8695933a39c8fe0b3f871 SHA512 0ec5c030fcc8b2073a3c524a5611e9861416523c73639aa3859d6c4bc1e69e2452c9e883f535129313db724b6bd48f00592d94321405450dbd9f4a9fdc3edb5b
diff --git a/www-servers/pshs/metadata.xml b/www-servers/pshs/metadata.xml
index d91d4566c345..7de6acc6c6af 100644
--- a/www-servers/pshs/metadata.xml
+++ b/www-servers/pshs/metadata.xml
@@ -15,7 +15,7 @@
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>https://github.com/mgorny/pshs/issues/</bugs-to>
- <remote-id type="github">mgorny/pshs</remote-id>
+ <bugs-to>https://github.com/projg2/pshs/issues/</bugs-to>
+ <remote-id type="github">projg2/pshs</remote-id>
</upstream>
</pkgmetadata>
diff --git a/www-servers/pshs/pshs-0.4.2.ebuild b/www-servers/pshs/pshs-0.4.2.ebuild
new file mode 100644
index 000000000000..3af2af814cfd
--- /dev/null
+++ b/www-servers/pshs/pshs-0.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
+HOMEPAGE="https://github.com/projg2/pshs/"
+SRC_URI="
+ https://github.com/projg2/pshs/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+magic qrcode ssl upnp"
+
+DEPEND="
+ >=dev-libs/libevent-2:0=
+ magic? ( sys-apps/file:0= )
+ qrcode? ( media-gfx/qrencode:0= )
+ ssl? (
+ >=dev-libs/libevent-2.1:0=[ssl]
+ dev-libs/openssl:0=
+ )
+ upnp? ( net-libs/miniupnpc:0= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature magic libmagic)
+ $(meson_feature qrcode qrencode)
+ $(meson_feature ssl)
+ $(meson_feature upnp)
+ )
+
+ meson_src_configure
+}