summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-01 15:19:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-01 15:36:17 +0200
commitf861e691e1488fdff3cc14a1958711289e076c76 (patch)
tree7e8338ffbe633ef84d44415454147938fe2d8092
parentdev-libs/nettle: migrate to USE=cpu_flags_arm_neon (diff)
downloadgentoo-f861e691.tar.gz
gentoo-f861e691.tar.bz2
gentoo-f861e691.zip
dev-python/argcomplete: Fix XPASS with fish 3.1.0
Closes: https://bugs.gentoo.org/720216 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild4
-rw-r--r--dev-python/argcomplete/files/argcomplete-1.11.1-fish-xpass.patch35
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
index 47957f564adc..b8764d725fa4 100644
--- a/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
+++ b/dev-python/argcomplete/argcomplete-1.11.1-r1.ebuild
@@ -31,6 +31,10 @@ BDEPEND="
>=dev-python/pip-19
)"
+PATCHES=(
+ "${FILESDIR}"/argcomplete-1.11.1-fish-xpass.patch
+)
+
python_test() {
"${EPYTHON}" test/test.py -v || die
}
diff --git a/dev-python/argcomplete/files/argcomplete-1.11.1-fish-xpass.patch b/dev-python/argcomplete/files/argcomplete-1.11.1-fish-xpass.patch
new file mode 100644
index 000000000000..575c8abbb744
--- /dev/null
+++ b/dev-python/argcomplete/files/argcomplete-1.11.1-fish-xpass.patch
@@ -0,0 +1,35 @@
+From 08bfc8a788e8081515d733e67be026d051c726f7 Mon Sep 17 00:00:00 2001
+From: Evan <evanunderscore@gmail.com>
+Date: Thu, 19 Mar 2020 14:55:07 +1100
+Subject: [PATCH] Remove expected test failure for new versions of fish (#292)
+
+---
+ test/test.py | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/test/test.py b/test/test.py
+index e91352b..2c34806 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -28,6 +28,8 @@
+
+ BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
+ BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
++FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
++FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
+
+
+ class TempDir(object):
+@@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
+ expected_failures = [
+ 'test_parse_special_characters',
+ 'test_comp_point',
+- 'test_special_characters_double_quoted'
+ ]
++ if FISH_VERSION_TUPLE < (3, 1):
++ expected_failures.extend([
++ 'test_special_characters_double_quoted'
++ ])
+
+ skipped = [
+ 'test_single_quotes_in_single_quotes',