summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-03-24 06:32:48 +0100
committerJeroen Roovers <jer@gentoo.org>2016-03-24 06:32:48 +0100
commitf8699e0c517c133a9c0ecb6bdeb7862609d5ceda (patch)
tree2c66d260794146f7bfdc3f8f9a567cc69fbd1b9f
parentdev-libs/libmaxminddb: Version bump. (diff)
downloadgentoo-f8699e0c517c133a9c0ecb6bdeb7862609d5ceda.tar.gz
gentoo-f8699e0c517c133a9c0ecb6bdeb7862609d5ceda.tar.bz2
gentoo-f8699e0c517c133a9c0ecb6bdeb7862609d5ceda.zip
net-analyzer/nmap: Version bump.
Package-Manager: portage-2.2.28
-rw-r--r--net-analyzer/nmap/Manifest1
-rw-r--r--net-analyzer/nmap/nmap-7.11.ebuild169
2 files changed, 170 insertions, 0 deletions
diff --git a/net-analyzer/nmap/Manifest b/net-analyzer/nmap/Manifest
index 1e897a6f9660..5d5fe0a35435 100644
--- a/net-analyzer/nmap/Manifest
+++ b/net-analyzer/nmap/Manifest
@@ -2,4 +2,5 @@ DIST nmap-6.47.tar.bz2 7878122 SHA256 8fa11e9e203ce2d81a207db5ca4f110a525f6c01c1
DIST nmap-7.00.tar.bz2 8918906 SHA256 9f442301c615c608a385831c3505cdfed9b0795cd100f1a258b04509802802ae SHA512 f8b4368de5956698e76a2a102102feb4bd00338cf983bfbf7bcd8c941288bb4a02c45469724e8a1daed87f41536a3f16a68fc604171fe23093575ac631637351 WHIRLPOOL f769a28b32c24874eb3d4fc3100ae1e7f271bc54837f992505754f31104de18a12116350b3fbf3402719d7e84110054e8f4fb7ea18ffa3b45f17fab8554998eb
DIST nmap-7.01.tar.bz2 8922697 SHA256 cf1fcd2643ba2ef52f47acb3c18e52fa12a4ae4b722804da0e54560704627705 SHA512 8b37616c2af2134a5a3bb292f25f2bc0232e20e08405620734c07d84bbc9070a87db4d4b14e8a10c67a3684960035ed202be5dd6feddfb613c134208fc62a2a7 WHIRLPOOL 612ad1e98fb0e52b4a85305ab4a1ef21b225a6457d6af09747651eae82c2601edb2b817add01e46c7f4831ed30353917d699b6cc82e67f30a2494dc41fee1d31
DIST nmap-7.10.tar.bz2 8947277 SHA256 58cf8896d09057d1c3533f430c06b22791d0227ebbb93dede2ccb73693ed4b4b SHA512 38bdbc1902875db150faf2051d90d4200dd3c2ca2abbd7dbe55981899e90c1ab173f84d9d76f1a3d4d3ff1edf927373f948c12cfcb0eae79d8ede20607308e6f WHIRLPOOL 1155d7f673ec2c87457781d56065eeeed8363ede66a1b36bc0d7e3cb10c34266cbd432d4333d8c13fc01a6cdb0d4f3f30d79258a7b1d97fc359bcc9bf9269a8f
+DIST nmap-7.11.tar.bz2 8960056 SHA256 13fa971555dec00e495a5b72c1f9efa1363b8e6c7388a2f05117cb0778c0954a SHA512 d64481afaa1cb1e70261a21ccff935bb7d45966f78f03a653d0cd32719bd7b13c05938716f906eb9f4b12d80ac772fb7e4dd434048fb947712267d73073f69f5 WHIRLPOOL e22b6bf9019f45d1c2017be0ca7f129bdc40d09df597b3ae50280dd6c9c67839b989fb562520d1c46f617c5280e7e10f35d0e42f8be4a033cc0f0250e0dd999e
DIST nmap-logo-64.png 3289 SHA256 4c72ff1eeffeeaa1039b251d9f2d675936e65db686fe3b57a35c2183ce67a8aa SHA512 fb102d12aaeebc8a97543ecd653a3606e86996ad679bc26d6e6e274ad05ec3e9f92521289d1a24153c521b699e8c0cfa65d8856bb49af53ee4837268bbc6b5d3 WHIRLPOOL 6093aadcb9880587e17d39d45fcbe57bb62777f220655e6ed5b5f900ce49cb8c5a53e24d7db0de6f8909eb0f8981f7565e6ae9b9bf9283a4ccccb0526eab5313
diff --git a/net-analyzer/nmap/nmap-7.11.ebuild b/net-analyzer/nmap/nmap-7.11.ebuild
new file mode 100644
index 000000000000..6eb5dd2fa007
--- /dev/null
+++ b/net-analyzer/nmap/nmap-7.11.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+inherit eutils flag-o-matic python-single-r1 toolchain-funcs
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network discovery and security auditing"
+HOMEPAGE="http://nmap.org/"
+SRC_URI="
+ http://nmap.org/dist/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~jer/nmap-logo-64.png
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+IUSE="ipv6 libressl +nse system-lua ncat ndiff nls nmap-update nping ssl zenmap"
+NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
+IUSE+=" ${NMAP_LINGUAS[@]/#/linguas_}"
+
+REQUIRED_USE="
+ system-lua? ( nse )
+ ndiff? ( ${PYTHON_REQUIRED_USE} )
+ zenmap? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ dev-libs/liblinear:=
+ dev-libs/libpcre
+ net-libs/libpcap[ipv6?]
+ zenmap? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ system-lua? ( >=dev-lang/lua-5.2[deprecated] )
+ ndiff? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ nmap-update? ( dev-libs/apr dev-vcs/subversion )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use ndiff || use zenmap; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_unpack() {
+ # prevent unpacking the logo
+ unpack ${MY_P}.tar.bz2
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.75-nolua.patch \
+ "${FILESDIR}"/${PN}-5.10_beta1-string.patch \
+ "${FILESDIR}"/${PN}-5.21-python.patch \
+ "${FILESDIR}"/${PN}-6.46-uninstaller.patch \
+ "${FILESDIR}"/${PN}-6.47-no-libnl.patch \
+ "${FILESDIR}"/${PN}-6.49-no-FORTIFY_SOURCE.patch \
+ "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
+
+ if use nls; then
+ local lingua=''
+ for lingua in ${NMAP_LINGUAS[@]}; do
+ if ! use linguas_${lingua}; then
+ rm -r zenmap/share/zenmap/locale/${lingua} || die
+ rm zenmap/share/zenmap/locale/${lingua}.po || die
+ fi
+ done
+ else
+ # configure/make ignores --disable-nls
+ for lingua in ${NMAP_LINGUAS[@]}; do
+ rm -r zenmap/share/zenmap/locale/${lingua} || die
+ rm zenmap/share/zenmap/locale/${lingua}.po || die
+ done
+ fi
+
+ sed -i \
+ -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
+ Makefile.in || die
+
+ sed -i \
+ -e '/rm -f $@/d' \
+ $(find . -name Makefile.in) \
+ || die
+
+ # Fix desktop files wrt bug #432714
+ sed -i \
+ -e '/^Encoding/d' \
+ -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
+ zenmap/install_scripts/unix/zenmap-root.desktop \
+ zenmap/install_scripts/unix/zenmap.desktop || die
+
+ epatch_user
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with zenmap) \
+ $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+ $(use_with ncat) \
+ $(use_with ndiff) \
+ $(use_with nmap-update) \
+ $(use_with nping) \
+ $(use_with ssl openssl) \
+ --with-libdnet=included \
+ --with-pcre=/usr
+ # --with-liblinear=/usr \
+ # Commented because configure does weird things, while autodetection works
+}
+
+src_compile() {
+ local directory
+ for directory in . libnetutil nsock/src \
+ $(usex ncat ncat '') \
+ $(usex nmap-update nmap-update '') \
+ $(usex nping nping '')
+ do
+ emake -C "${directory}" makefile.dep
+ done
+
+ emake \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ LC_ALL=C emake -j1 \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+ if use nmap-update;then
+ LC_ALL=C emake -j1 \
+ -C nmap-update \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+ fi
+
+ dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+ if use zenmap; then
+ doicon "${DISTDIR}/nmap-logo-64.png"
+ python_optimize
+ fi
+}