summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 14:06:14 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 14:06:14 +0100
commitf86e19d231bbf7e41dc2a6c919e688fb46058560 (patch)
tree81d951e9f44db775bc87372101401c40e4c6bed2
parentdev-python/ptpython: Remove old (diff)
downloadgentoo-f86e19d2.tar.gz
gentoo-f86e19d2.tar.bz2
gentoo-f86e19d2.zip
dev-python/pushbullet-py: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/pushbullet-py/Manifest1
-rw-r--r--dev-python/pushbullet-py/files/pushbullet-py-0.10.0-fix-filetypes-python3.patch28
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.10.0.ebuild54
3 files changed, 0 insertions, 83 deletions
diff --git a/dev-python/pushbullet-py/Manifest b/dev-python/pushbullet-py/Manifest
index 4d6b812f9d32..23ad44b78bd8 100644
--- a/dev-python/pushbullet-py/Manifest
+++ b/dev-python/pushbullet-py/Manifest
@@ -1,2 +1 @@
-DIST pushbullet-py-0.10.0.tar.gz 18929 BLAKE2B 900e42ce407a0baff0b24cbe6e04a3c10e1aeb9f7dbfc917cd58b2c35a2f42f81c0aa935fecdbd50d087a45d309b9baad1e3e5235568461b3e54c12874a2ac93 SHA512 2e259b76413c5e644350a891678eb98f761e56b18f5a06a9d7cc34353c7c7ee67fa875aed575b1b005782b21f4440d682db5c09be7033d52b7b9cf41e9120123
DIST pushbullet.py-0.11.0.tar.gz 21653 BLAKE2B a6c9b6f4958ce35b63ea4043d1d4f8691885bd0aa2927af541f2080a0b0b65a7df979a497967f3adceab8ad2382448a4c6a02d1184c9d72a18d91844eb970722 SHA512 b236f30b99e5bb79eff183529716c1c8f83cfd2526fdf50d86041eb6d3fcd6670d0c4dce407ae6e50aea0fa96d6a5527af980148f0c71ef758c480f972ad9659
diff --git a/dev-python/pushbullet-py/files/pushbullet-py-0.10.0-fix-filetypes-python3.patch b/dev-python/pushbullet-py/files/pushbullet-py-0.10.0-fix-filetypes-python3.patch
deleted file mode 100644
index 09ded3540487..000000000000
--- a/dev-python/pushbullet-py/files/pushbullet-py-0.10.0-fix-filetypes-python3.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/pushbullet/filetype.py b/pushbullet/filetype.py
-index a2f2be0..22ffedf 100644
---- a/pushbullet/filetype.py
-+++ b/pushbullet/filetype.py
-@@ -1,13 +1,22 @@
- def _magic_get_file_type(f, _):
- file_type = magic.from_buffer(f.read(1024), mime=True)
- f.seek(0)
-- return file_type.decode('utf-8')
-+ return maybe_decode(file_type)
-
-
- def _guess_file_type(_, filename):
- return mimetypes.guess_type(filename)[0]
-
-
-+# return str on python3. Don't want to unconditionally
-+# decode because that results in unicode on python2
-+def maybe_decode(s):
-+ if str == bytes:
-+ return s.decode('utf-8')
-+ else:
-+ return s
-+
-+
- try:
- import magic
- except ImportError:
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.10.0.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.10.0.ebuild
deleted file mode 100644
index aa276aa6ff09..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.10.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="https://github.com/randomchars/pushbullet.py"
-# tests and examples are missing from PyPI tarballs
-# https://github.com/randomchars/pushbullet.py/pull/104
-SRC_URI="https://github.com/randomchars/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# Backport from upstream git
-PATCHES=( "${FILESDIR}/${P}-fix-filetypes-python3.patch" )
-
-python_test() {
- # skip tests which require network access
- PUSHBULLET_API_KEY= py.test \
- -k "not test_auth" || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}