summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-10-26 21:11:28 +0200
committerSam James <sam@gentoo.org>2023-05-06 04:48:28 +0100
commitf87038fdfed2d1a891417ef921b4de4f0a953fd5 (patch)
tree4c3caad390a10088380da9f0f713b4c2c66aed02
parentdev-db/sqlmap: drop 1.7.2 (diff)
downloadgentoo-f87038fdfed2d1a891417ef921b4de4f0a953fd5.tar.gz
gentoo-f87038fdfed2d1a891417ef921b4de4f0a953fd5.tar.bz2
gentoo-f87038fdfed2d1a891417ef921b4de4f0a953fd5.zip
dev-python/nextinspace: new package, add 2.0.5, 9999
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/27965 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/nextinspace/Manifest1
-rw-r--r--dev-python/nextinspace/metadata.xml22
-rw-r--r--dev-python/nextinspace/nextinspace-2.0.5.ebuild43
-rw-r--r--dev-python/nextinspace/nextinspace-9999.ebuild43
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/nextinspace/Manifest b/dev-python/nextinspace/Manifest
new file mode 100644
index 000000000000..ca45cfafa5b3
--- /dev/null
+++ b/dev-python/nextinspace/Manifest
@@ -0,0 +1 @@
+DIST nextinspace-2.0.5.gh.tar.gz 48406 BLAKE2B 6f6e2c95fc1a5a8175faca4df0a51de9996ca24847926dc35b94d0e4bd5c9de880ad757606309f622f41c825d0c2e46c587f255573b4df70fe35c937148af9d7 SHA512 c8f55446d9eea0409afb8a8ddb41001b18b55d9105d007b306717a3d932ea1b03ecb2363d0deb42ec8da1cc245b77ffb18cee6ec3474121c15c4c9b79ff80405
diff --git a/dev-python/nextinspace/metadata.xml b/dev-python/nextinspace/metadata.xml
new file mode 100644
index 000000000000..56879b2e53b6
--- /dev/null
+++ b/dev-python/nextinspace/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A command-line tool for seeing the latest in space. Nextinspace also
+ supports use as a Python library, so you can integrate it into your
+ application. You can also get data printed to the terminal in JSON,
+ which can be piped into another program.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">gideonshaked/nextinspace</remote-id>
+ <remote-id type="pypi">nextinspace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nextinspace/nextinspace-2.0.5.ebuild b/dev-python/nextinspace/nextinspace-2.0.5.ebuild
new file mode 100644
index 000000000000..81347649c9dc
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-2.0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-lazy-fixture-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Don't install license files
+ sed -e '/^include = \["LICENSE"\]$/d' -i pyproject.toml || die
+}
diff --git a/dev-python/nextinspace/nextinspace-9999.ebuild b/dev-python/nextinspace/nextinspace-9999.ebuild
new file mode 100644
index 000000000000..81347649c9dc
--- /dev/null
+++ b/dev-python/nextinspace/nextinspace-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="A command-line tool for seeing the latest in space"
+HOMEPAGE="https://github.com/gideonshaked/nextinspace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gideonshaked/nextinspace.git"
+else
+ SRC_URI="https://github.com/gideonshaked/nextinspace/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/colorama-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-lazy-fixture-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ # Don't install license files
+ sed -e '/^include = \["LICENSE"\]$/d' -i pyproject.toml || die
+}