summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-14 07:46:26 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-14 09:07:59 +0100
commitf87a5336d28fc191a5cfd86da5010e937183b28c (patch)
tree8f6044d21592f927e2c2e5359f672082bf153605
parentdev-python/botocore: Bump to 1.23.35 (diff)
downloadgentoo-f87a5336d28fc191a5cfd86da5010e937183b28c.tar.gz
gentoo-f87a5336d28fc191a5cfd86da5010e937183b28c.tar.bz2
gentoo-f87a5336d28fc191a5cfd86da5010e937183b28c.zip
dev-python/boto3: Bump to 1.20.35
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.35.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1fcac0dbdc3b..5073d6de48e9 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,4 +8,5 @@ DIST boto3-1.20.31.tar.gz 458553 BLAKE2B 396acd8bbc47f76a0ba65da4b83f141f2536903
DIST boto3-1.20.32.tar.gz 459036 BLAKE2B 21aaba2f5f5db65edc3570e44082cf394429407c0431bdfc19866e530b48358909ab730ecb5b871dcbb5f4c087af43f53474a7dca6ce9ca84e78ba480f5cc819 SHA512 a50f0724f4c6ab8b0fc0b329909ff35126bbdc9c73da5927dd1259565b2e43e87c718bbf8b2dd5433e75b4d35b8094d3fc122163febbbe66b6175ecfeb81fad9
DIST boto3-1.20.33.tar.gz 459654 BLAKE2B bf2090e6af9cad5f4e9e5178d30e109c63c403137f9656c22358bb672da7e0ca2e9f36585b5721f2a7bbb2d3d3027fb3942e055d3db78ede0b03f5b6a2e6ad78 SHA512 877c8e59686cd7ac940aa7fb1f2adc75a89e4ce5c74e7a999bebe80e80819c6f909ee8f9acca1c85a6a11f3b7a8ba39a41221ec54a8b99c412da9208a791f4b3
DIST boto3-1.20.34.tar.gz 460169 BLAKE2B d687bb3a90da0e8cd48e551dad68754edc97689350f43879c90e8c96470dc79d389b5332d06d079dd4d26f303d9260f1a83bfc2edfa2507e3a33020e4475e8f1 SHA512 ae13db5ed516a9166c14e72e078f45c911a9c16edc2e2d95dc296de09345fb311ecad92ec7615137b01edaae254d075b74e68c1c909a79b2eb1ac2416ab5bbad
+DIST boto3-1.20.35.tar.gz 460636 BLAKE2B 4ec04ae5caac912beb4933727ef0f8f1266b9ab27788a98d7ae10fc8b19a79e3deeed0ce6c1156f12ad12062df24828909fff070813fae4efc705b5e7babc2b1 SHA512 59fcaf477d5d67d68dcc007d93391b71ad8d04d46fc3c098c3f0fb7c82806a1a37999bdb292a240862dbaf83a6c2890d947315d1d9a4faeae68fb9e896cae73b
DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5793f8bfb210b52bbc09e39e6fe06a957951375e0795210dc1c3b2a0afd2f498bc88e449d9e6846f2b357f016 SHA512 2823466e4851684253d4ce42a8c34e5cbdad6d04c823040fe2cebdf0cffb14d5d3f40e28d57ebec14533fab04ba74f27c25f078ddb8791b8f52d0424e11b39fc
diff --git a/dev-python/boto3/boto3-1.20.35.ebuild b/dev-python/boto3/boto3-1.20.35.ebuild
new file mode 100644
index 000000000000..0d5810a8ffe0
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.35.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}