summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-07 05:03:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-07 05:15:08 +0200
commitf87f674026516dc13c1c39ce371b34566b967555 (patch)
tree8ded2a1ae18cfc22f5468b378af5b0d06648dbac
parentdev-python/pytest-rerunfailures: Bump to 12.0 (diff)
downloadgentoo-f87f674026516dc13c1c39ce371b34566b967555.tar.gz
gentoo-f87f674026516dc13c1c39ce371b34566b967555.tar.bz2
gentoo-f87f674026516dc13c1c39ce371b34566b967555.zip
dev-python/pyaml: Bump to 23.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyaml/Manifest1
-rw-r--r--dev-python/pyaml/pyaml-23.7.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyaml/Manifest b/dev-python/pyaml/Manifest
index c4d5218f1492..151d6bf40300 100644
--- a/dev-python/pyaml/Manifest
+++ b/dev-python/pyaml/Manifest
@@ -1 +1,2 @@
DIST pyaml-23.5.9.tar.gz 20234 BLAKE2B a6ff24e82eb25aa309466c56e5c2d4543b2ed972f4eb71c12023ae71d2fb3ddcd0824d890e475ceca9360f3e5d0ea755f4733448e1f2282dca82b6f313cd0b34 SHA512 ba6a7d51208b10a2265a52c684d43052fb57a7cd1fc4a4087a141a3adfc36f54b71e943056f346c26ae1b16800b8f2c3a2c0c20454322c9a24b760993c9dd49d
+DIST pyaml-23.7.0.tar.gz 20805 BLAKE2B 797b2b5d2121f3b0f67445d4b3a55b13d0716d5eddd5dc83a08b767d293b486e9985203f4e2571a7c8d3010b9cac9093e9353517f6414cd5b89cdcfe5d39c85a SHA512 edbe58a3a7f1216a2463ac56af829c38b12b7194429691a92cb7f28ca926094e324d6e44d3fb64be40239dc8a6dc61d72946b107f5210ca83e73dec18b1428ef
diff --git a/dev-python/pyaml/pyaml-23.7.0.ebuild b/dev-python/pyaml/pyaml-23.7.0.ebuild
new file mode 100644
index 000000000000..a49398baeb97
--- /dev/null
+++ b/dev-python/pyaml/pyaml-23.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="
+ https://github.com/mk-fg/pretty-yaml/
+ https://pypi.org/project/pyaml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest