summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-01 14:53:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-01 14:53:37 +0200
commitf89e1f5bacb79afd9f863f9f0223ef2f5316f7d0 (patch)
tree884e351178bbfc0730fc17f9cb4efe647a42f96c
parentdev-python/click: Remove old (diff)
downloadgentoo-f89e1f5b.tar.gz
gentoo-f89e1f5b.tar.bz2
gentoo-f89e1f5b.zip
dev-python/flask-login: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-login/Manifest1
-rw-r--r--dev-python/flask-login/files/flask-login-0.5.0-fix-tests-py3.10.patch26
-rw-r--r--dev-python/flask-login/flask-login-0.5.0.ebuild39
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/flask-login/Manifest b/dev-python/flask-login/Manifest
index 866e813dab6b..22e1532de5fa 100644
--- a/dev-python/flask-login/Manifest
+++ b/dev-python/flask-login/Manifest
@@ -1,2 +1 @@
-DIST flask-login-0.5.0.tar.gz 44961 BLAKE2B a780a3ca1ced7f01cbc1f99e3d92f57819c73982a4098330be7b9b4dce88e5fac577d15b2989b99971c4b2f7e6c9f02a54aeab9f7fa1c101f409cbdcfa3c6942 SHA512 8ffecd2a512738f81ec3901ad30d356b1d63355268f7cf1b427e463d0a271a4623723255e139bbd0f88845d73fa4aab051418b5f68aef0b4576c30294f6207b3
DIST flask-login-0.6.0.gh.tar.gz 47368 BLAKE2B 799591ec0bd538e6cc467a80b3a8891a97ee60bbfcf01eb6ba7be1ab48e7ea9be22e8777801621b39bf089c00d7914f7b045e4e6617e45d623354276ba7e245b SHA512 0766ef5702105bc2cea7082b2b2a9bebed282a9166757adbc91a02c4adcc291d41a3217e8b9566b6bb4778db4a1d2453edb0b7a727c9bff2673833d27b69148e
diff --git a/dev-python/flask-login/files/flask-login-0.5.0-fix-tests-py3.10.patch b/dev-python/flask-login/files/flask-login-0.5.0-fix-tests-py3.10.patch
deleted file mode 100644
index 858783b36e77..000000000000
--- a/dev-python/flask-login/files/flask-login-0.5.0-fix-tests-py3.10.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From: Karthikeyan Singaravelan <tir.karthi@gmail.com>
-Date: Sun, 10 Jan 2021 21:12:36 +0530
-Subject: [PATCH] Import ABC from collections.abc (#525)
-
---- a/test_login.py
-+++ b/test_login.py
-@@ -12,6 +12,10 @@
- from mock import ANY, patch, Mock
- except ImportError:
- from unittest.mock import ANY, patch, Mock
-+try:
-+ from collections.abc import Hashable
-+except ImportError:
-+ from collections import Hashable
- from semantic_version import Version
-
-
-@@ -1548,7 +1552,7 @@ def test_equality(self):
- self.assertTrue(first != u'1')
-
- def test_hashable(self):
-- self.assertTrue(isinstance(UserMixin(), collections.Hashable))
-+ self.assertTrue(isinstance(UserMixin(), Hashable))
-
-
- class AnonymousUserTestCase(unittest.TestCase):
diff --git a/dev-python/flask-login/flask-login-0.5.0.ebuild b/dev-python/flask-login/flask-login-0.5.0.ebuild
deleted file mode 100644
index e0a82f661725..000000000000
--- a/dev-python/flask-login/flask-login-0.5.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Login session support for Flask"
-HOMEPAGE="https://pypi.org/project/Flask-Login/"
-# Should be replaced with the PyPi URI for the next release, if possible
-# See https://github.com/maxcountryman/flask-login/pull/393
-SRC_URI="https://github.com/maxcountryman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- >=dev-python/flask-0.10[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/semantic_version[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-tests-py3.10.patch"
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}