summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-23 19:40:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-23 19:40:25 +0100
commitf8bc77b745976f6d62be15c77eb869fcb8e65588 (patch)
tree1e3d10f0ba353f22d2e37c7b1d06a518ffbdeea6
parentdev-python/rosdistro: add python3.5 support (diff)
downloadgentoo-f8bc77b7.tar.gz
gentoo-f8bc77b7.tar.bz2
gentoo-f8bc77b7.zip
dev-python/vcstools: remove old
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-python/vcstools/Manifest1
-rw-r--r--dev-python/vcstools/vcstools-0.1.37.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/vcstools/Manifest b/dev-python/vcstools/Manifest
index 51d033aa1bb4..bad9fdca4b21 100644
--- a/dev-python/vcstools/Manifest
+++ b/dev-python/vcstools/Manifest
@@ -1,2 +1 @@
-DIST vcstools-0.1.37.tar.gz 54213 SHA256 8d66379c5e5772a42b9680c9120a718bdc904745be22096d1f2bd5934cd625fc SHA512 c2992fd9977dd5cb0090319b828add26f60769bb7649d873e8edcac45c23a913667cde31f7ab658d5ce7de82930a5eb0ea9083994ea93b6ee9433966e70ee7b2 WHIRLPOOL aea89a863217ad09e2d183aa04f5c5173f6e7330ff2bfa1e713ab910f3ad0017e95fbf69c1cd94c10e20b7baa5974ad40fe9efda546860ef2a35f100808eb09e
DIST vcstools-0.1.38.tar.gz 54671 SHA256 0e3d2b5681c2776453fb5b61ceab61fdb965d5342e46c08a5b62095eb0237117 SHA512 a3693d34777235e562a5db006af8f33590df99ffce96f5d3cfd2d816ebdc23ee5fb3536bf289b64a36588e60ce20ce8396a448394f300a12672fd8bf5800973e WHIRLPOOL 86fccbb181849f2b60d8159073bb3de659b7d96173952cb9b68a2869048827c48860fb67859db1341a0defeee0915d41c1d6e77e812f807ca11e91e92e0ed250
diff --git a/dev-python/vcstools/vcstools-0.1.37.ebuild b/dev-python/vcstools/vcstools-0.1.37.ebuild
deleted file mode 100644
index d7a8169479ef..000000000000
--- a/dev-python/vcstools/vcstools-0.1.37.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/vcstools/vcstools"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Python library for interacting with various VCS systems"
-HOMEPAGE="http://wiki.ros.org/vcstools"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- http://github.com/vcstools/vcstools/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-vcs/git
- dev-vcs/bzr
- dev-vcs/mercurial
- dev-vcs/subversion
- )
-"
-
-python_test() {
- # From travis.yml
- # Set git config to silence some stuff in the tests
- git config --global user.email "foo@example.com"
- git config --global user.name "Foo Bar"
- # Set the hg user
- echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
- # Set the bzr user
- bzr whoami "Your Name <name@example.com>"
- #git config --global user.email "you@example.com"
- #git config --global user.name "Your Name"
-
- nosetests --with-coverage --cover-package vcstools || die
-}