summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-02 15:37:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-02 15:54:23 +0100
commitf8ceb7d9e658d13f9cf0521377c783032a4b543c (patch)
tree17c453e9b19160d3fdac673a9202cb1a6c29d546
parentdev-python/watchdog: Bump to 2.2.1 (diff)
downloadgentoo-f8ceb7d9.tar.gz
gentoo-f8ceb7d9.tar.bz2
gentoo-f8ceb7d9.zip
dev-python/pygments: Bump to 2.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.14.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 0671aac32415..287197044b24 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1 +1,2 @@
DIST Pygments-2.13.0.tar.gz 4324285 BLAKE2B 6edbce4827684baf61c571fe4d900fd8d1850c49ed9a2ec4bf674757b17efc3d933145f0ccb743d5f713887dff95abce58d38ceafb4d5b033d46afbf5645c6fe SHA512 d492acf112423fa997f35d6d3cae18b89bf11619c696879c6df49697dca933b6d54d7cb22907e06812e0a562f03e8ed5ccefde5247bc1c51cf2d3d69e7d65422
+DIST Pygments-2.14.0.tar.gz 4434562 BLAKE2B a3050bae96a8ae044f803e7964b5dede7a73b04f04f6af9d4b9e4d24e3ae0185138d0d68801ee5ac81cdaf74e50c7fea303913470c23182adb30ff2c08c332a8 SHA512 51416a8e2a8d0288cbbf6fd81e6870ffe9d999da255c43d0f870eb5cb4d01660416d136d39fad38b76c4bace3c3aa648fb306519e85e340545a87fc657aaeb15
diff --git a/dev-python/pygments/pygments-2.14.0.ebuild b/dev-python/pygments/pygments-2.14.0.ebuild
new file mode 100644
index 000000000000..d5acb87947ca
--- /dev/null
+++ b/dev-python/pygments/pygments-2.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1 bash-completion-r1
+
+MY_P=${P^}
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}