summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-01-05 09:25:48 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-01-05 09:25:48 +0100
commitf8de6b7c584a420905598d5c308fdf9f513ce2da (patch)
tree2d72a3505abc0d46191e5f88646f86811125905e
parentmedia-libs/libkeyfinder: removed obsolete 2.2.4 (diff)
downloadgentoo-f8de6b7c.tar.gz
gentoo-f8de6b7c.tar.bz2
gentoo-f8de6b7c.zip
media-libs/libkeyfinder: bump to 2.2.6
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-libs/libkeyfinder/Manifest1
-rw-r--r--media-libs/libkeyfinder/libkeyfinder-2.2.6.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/libkeyfinder/Manifest b/media-libs/libkeyfinder/Manifest
index 9f852f667e87..7220d2eb5578 100644
--- a/media-libs/libkeyfinder/Manifest
+++ b/media-libs/libkeyfinder/Manifest
@@ -1 +1,2 @@
DIST libkeyfinder-2.2.5.tar.gz 79220 BLAKE2B a0a9b6b0d392d8da7be479e30a733f64f0c0723a1890a969ff1cc0ffc56599778148f7fe081724e83f1b3cc2217bb52f46418ed328da7d34d9229aabf24cbaef SHA512 54463d1f1111dc474d3e43723fddd5579ea1a3842f99f43e50e85622a1d6ee6fe42b22c300ce5ba5807cf6b2d7067af741773af95974a42c5d863c53165893eb
+DIST libkeyfinder-2.2.6.tar.gz 79371 BLAKE2B dbc1b531098686169cf358a631ce2dfd8d053df93cbcc31b4fd1320ee01f84e60f0b4e290d57b31f0ba09b7d81430574b98dbc4a181953119a732f019c437f48 SHA512 c1b771cebfb925db521a344e28fd1d3bc6e6e921e45dcc81f90926e5b2020fea201a4bc05a65177d3559208a45746fd7784eb6f37352bb10ab7d7b820b40c0b6
diff --git a/media-libs/libkeyfinder/libkeyfinder-2.2.6.ebuild b/media-libs/libkeyfinder/libkeyfinder-2.2.6.ebuild
new file mode 100644
index 000000000000..4b58f20bc804
--- /dev/null
+++ b/media-libs/libkeyfinder/libkeyfinder-2.2.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Musical key detection library for digital audio"
+HOMEPAGE="https://github.com/mixxxdj/libkeyfinder"
+SRC_URI="https://github.com/mixxxdj/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/fftw:3.0
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/NAMES fftw /NAMES /" \
+ cmake/FindFFTW3.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=OFF
+ )
+
+ cmake_src_configure
+}