summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-01-01 12:00:57 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-01-01 12:01:12 -0600
commitf8f1bb47e9b0f4526fdfe8ed5ec3abfa12ff7f8f (patch)
treed42da7253bc699e94e9efb5ca05ab863423fdb54
parentnet-im/zoom: add 5.13.3.651 (diff)
downloadgentoo-f8f1bb47.tar.gz
gentoo-f8f1bb47.tar.bz2
gentoo-f8f1bb47.zip
sys-block/tgt: add 1.0.85
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--sys-block/tgt/Manifest1
-rw-r--r--sys-block/tgt/tgt-1.0.85.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-block/tgt/Manifest b/sys-block/tgt/Manifest
index 9813f7433c18..eb028f063c62 100644
--- a/sys-block/tgt/Manifest
+++ b/sys-block/tgt/Manifest
@@ -1,2 +1,3 @@
DIST tgt-1.0.83.tar.gz 304631 BLAKE2B 64374e3ffa0fd73f25172e24b233d001dc2b70cbc08116f167de9d625d493dca330e84f73683d6cc74ea76f5bd9fa940cec54d43ebc9c41ed1ff54f5dc3a6e39 SHA512 0c97900aada010b84585a7ad2b1c4654db0fdbc4caed1dea05d00518340b23691ba91f4bb3c677b420a3f4e67f4b061055f877c050ea1d758f2ebb75771b1cf5
DIST tgt-1.0.84.tar.gz 304641 BLAKE2B d5a28547ba637d951b4096ae3e2b49794aac0a7e517f185331fdfa7df9a1715ce82d498f88538fe08a71ba3958a6972251dbebafdddfeb649318c2ff13a72f95 SHA512 a194d95fac7c4525b22257af3977b1ca680d81bbf1aa4c75444f30a6d8d8db22eca3b29b2ece314fe3b0c0d18152e048c912347c9db1146c9f38419be5116971
+DIST tgt-1.0.85.tar.gz 304648 BLAKE2B fb2c004c9e4ac614b0dfd58d5e9f641b6ca061a716cfc2c7888eb205e461178f6b04c4bbddc7abd1fc797bd6623c265bc01fc73f75b83dfa84cc35656a306f61 SHA512 847e4c4f80e9bdc46910eb9ab49a150d985a8fcdb77e67eabf5eb12845d9faafee76f9b7a5d71d5b3504205288d77fcf3e0f04e7f835ab8ad829700c13d783d4
diff --git a/sys-block/tgt/tgt-1.0.85.ebuild b/sys-block/tgt/tgt-1.0.85.ebuild
new file mode 100644
index 000000000000..190b5c32a91a
--- /dev/null
+++ b/sys-block/tgt/tgt-1.0.85.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Linux SCSI target framework (tgt)"
+HOMEPAGE="http://stgt.sourceforge.net"
+SRC_URI="https://github.com/fujita/tgt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="fcoe fcp ibmvio infiniband rbd"
+
+DEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-perl/Config-General
+ rbd? ( sys-cluster/ceph )
+ infiniband? ( sys-cluster/rdma-core )
+"
+RDEPEND="${DEPEND}
+ dev-libs/libaio
+ sys-apps/sg3_utils"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:\($(CC)\) $^:\1 $(LDFLAGS) $^:' usr/Makefile || die
+ # make sure xml docs are generated before trying to install them
+ sed -i -e "s@install: @& all @g" doc/Makefile || die
+ sed -i -e 's|-Werror||g' usr/Makefile || die
+}
+
+src_compile() {
+ local myconf
+ use ibmvio && myconf="${myconf} IBMVIO=1"
+ use infiniband && myconf="${myconf} ISCSI_RDMA=1"
+ use fcp && myconf="${myconf} FCP=1"
+ use fcoe && myconf="${myconf} FCOE=1"
+ use rbd && myconf="${myconf} CEPH_RBD=1"
+
+ emake -C usr/ KERNELSRC="${KERNEL_DIR}" ISCSI=1 ${myconf}
+ emake -C doc
+}
+
+src_install() {
+ emake install-programs install-scripts install-doc DESTDIR="${D}" docdir=/usr/share/doc/${PF}
+ newinitd "${FILESDIR}"/tgtd.initd tgtd
+ newconfd "${FILESDIR}"/tgtd.confd tgtd
+ systemd_dounit "${S}"/scripts/tgtd.service
+ dodir /etc/tgt
+ keepdir /etc/tgt
+}