summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-01 14:53:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-01 18:17:44 +0200
commitf8f806e4e0d1918d4adb2181c6a96e413044587d (patch)
tree21a51c1cadb111312054143c549a441f3ca0500d
parentsys-devel/clang-runtime: Bump to 12.0.0-rc4 (diff)
downloadgentoo-f8f806e4.tar.gz
gentoo-f8f806e4.tar.bz2
gentoo-f8f806e4.zip
dev-python/signature_dispatch: New dep of dev-python/autoprop
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/signature_dispatch/Manifest1
-rw-r--r--dev-python/signature_dispatch/metadata.xml12
-rw-r--r--dev-python/signature_dispatch/signature_dispatch-0.1.0.ebuild20
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/signature_dispatch/Manifest b/dev-python/signature_dispatch/Manifest
new file mode 100644
index 000000000000..8bc55852b1ee
--- /dev/null
+++ b/dev-python/signature_dispatch/Manifest
@@ -0,0 +1 @@
+DIST signature_dispatch-0.1.0.tar.gz 8715 BLAKE2B c62f5d0b0b263e50215d588e83bab4b5ca6dff82f856ad6265a0bb2dd64e2a3a8dfd0b8989ec17424828575607bd4dccc5802ef072af271eddb88c2479e6b8e7 SHA512 687a1de540a61d274e93510d2c5a93c736a52587b0215aef91364e34ad8932b880361b53fb84e68f9c2083652fa97c759705b4d61bc74caeba73a4ff37b42785
diff --git a/dev-python/signature_dispatch/metadata.xml b/dev-python/signature_dispatch/metadata.xml
new file mode 100644
index 000000000000..1121e59ad090
--- /dev/null
+++ b/dev-python/signature_dispatch/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kalekundert/signature_dispatch</remote-id>
+ <remote-id type="pypi">signature-dispatch</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/signature_dispatch/signature_dispatch-0.1.0.ebuild b/dev-python/signature_dispatch/signature_dispatch-0.1.0.ebuild
new file mode 100644
index 000000000000..6b816f74012a
--- /dev/null
+++ b/dev-python/signature_dispatch/signature_dispatch-0.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Execute the first function that matches the given arguments"
+HOMEPAGE="
+ https://github.com/kalekundert/signature_dispatch/
+ https://pypi.org/project/signature-dispatch/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest