summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-14 23:44:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-14 23:44:31 +0200
commitf91c004b07c4182733a79fdfa2f1b809f967759e (patch)
tree065c7013fe7bb64192a0e3537be74acf66d4ba8f
parentdev-python/bleach: Bump to 3.3.1 (diff)
downloadgentoo-f91c004b.tar.gz
gentoo-f91c004b.tar.bz2
gentoo-f91c004b.zip
dev-python/botocore: Bump to 1.20.112
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.112.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 8c9a16561b3e..21b312f551ef 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,4 +6,5 @@ DIST botocore-1.20.108.tar.gz 7897833 BLAKE2B 3b4ee27640dbfce1c9923137ef21500649
DIST botocore-1.20.109.tar.gz 7900306 BLAKE2B 1f2009ccb236ff7b4d9d3b45b34b2295c9bbbd4bce207c51514bf3f568985eb3d5fedaf0e5309266f46ad1e42466524d148d601452474b738b53c329f0164a84 SHA512 7f266b2395f79bfa629ac147abbf646bf049ea78b208228b3817912626845fffac9c89419c75444116ae6f14067805e291faeb942e6d25061d2e6f1c382d762e
DIST botocore-1.20.110.tar.gz 7904149 BLAKE2B f503e9d4876820f669bd4ae12603498fe0a310fddd7a7c739a53b804391657c48144c43c2dd3606932c7e457d1e2324a5dba4885e93eaf7526d46080b565c6d8 SHA512 e33d8e9dbd212d06644882e60c9b6f2754a549727a22d73814798230561b3d766524f0a32b49cce8ac68c1cb47e58eab7047abe75bf7c37ef7b6857dd81d2dbc
DIST botocore-1.20.111.tar.gz 7909299 BLAKE2B d1eabf5d433d521258125f29b21efc58208bb58a23bc856d6397ee2da834d85728454644568784fb05ab08f4bc5536675166874536264690cf9244e433340763 SHA512 d08323e2ad0b17dcecf59edbea60920e0077b34582cc8e84c08ab4f8600b6b509ac98b8a415fcfa019682e9d22bf05ececfa2c0f96fd3c17ca2aa47fcdb4d903
+DIST botocore-1.20.112.tar.gz 7917776 BLAKE2B 6a5ebf3d32c505ec2c1fc4cd3d97aa94c76b6206dda6ba28a946dfdc9973073019389c05d1cf09a0eced701fe86a9b8a292835415c0b1ceea75959a3186f65c6 SHA512 4b36367ffdd011aeb7654fd5c52c38e95bae4c55e5af85e38b0764140539ad1f8b9d75b0c7fd1009fda8d005ef4b17673b06f85a76b52fcebf05925297b6bbbf
DIST botocore-1.20.97.tar.gz 7846552 BLAKE2B da0355cc229ba8a0632f67866bf06b27d7b257184b53670e5dc183c6b5a1f4d3a34145de0a3f04abd2adc08de3f0775e3c7e0dbecae729acb5bc05c7ce9acaf2 SHA512 7411d5de8ecf0c42c0142ded036189dcf378cd16f761071beb5bc2a2c240eabb0c4a8c669ce89a5b4e798a0aae92f0e67755627c2a84df77fc2e9557265a4e3b
diff --git a/dev-python/botocore/botocore-1.20.112.ebuild b/dev-python/botocore/botocore-1.20.112.ebuild
new file mode 100644
index 000000000000..30e0988848ad
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.112.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}