summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-12-14 13:08:57 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-02-09 10:42:20 +0100
commitf92882c778bc829aebb82ed7286d08fcb691b507 (patch)
treeeca800494b95a3fc2a1962ae7ce5e32b36f25821
parentdev-python/setuptools_scm: Remove old (diff)
downloadgentoo-f92882c778bc829aebb82ed7286d08fcb691b507.tar.gz
gentoo-f92882c778bc829aebb82ed7286d08fcb691b507.tar.bz2
gentoo-f92882c778bc829aebb82ed7286d08fcb691b507.zip
dev-java/lmax-disruptor: new package
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24106/commits/a4f55bc4aab5e0fa2ce865a8a73f43e192d7f7ba Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--dev-java/lmax-disruptor/Manifest1
-rw-r--r--dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild41
-rw-r--r--dev-java/lmax-disruptor/metadata.xml11
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-java/lmax-disruptor/Manifest b/dev-java/lmax-disruptor/Manifest
new file mode 100644
index 000000000000..07618fb8c6fc
--- /dev/null
+++ b/dev-java/lmax-disruptor/Manifest
@@ -0,0 +1 @@
+DIST lmax-disruptor-3.4.4.tar.gz 237165 BLAKE2B ff17747e24a587e4b0656e16281ecf98cad5b3f260cd270a87e157ccbd6afc4a4e0886fcfab774a3c7919a9f5d26e13199a3cbcd3f7699986d4f9a36576f72dd SHA512 871d474ecbc4e09d33b0d099232f2abdf88b755141e00406e4a721e5bd6c5edc99c6c446277e054bd603ae9b158bdb6b438aa6e8532194dca9bce953b748bfde
diff --git a/dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild b/dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild
new file mode 100644
index 000000000000..7965344532c6
--- /dev/null
+++ b/dev-java/lmax-disruptor/lmax-disruptor-3.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.lmax:disruptor:3.4.4"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A High Performance Inter-Thread Messaging Library"
+HOMEPAGE="https://lmax-exchange.github.io/disruptor/"
+SRC_URI="https://github.com/LMAX-Exchange/disruptor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( LICENCE.txt README.md )
+
+S="${WORKDIR}/disruptor-${PV}"
+
+JAVA_SRC_DIR="src/main"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test"
+JAVA_TEST_EXCLUDES=(
+ # valid test classes have pattern *Test with nothing behind
+ com.lmax.disruptor.dsl.stubs.TestWorkHandler # No runnable methods
+ com.lmax.disruptor.support.TestEvent # No runnable methods
+ com.lmax.disruptor.support.TestWaiter # No runnable methods
+)
+
+src_install() {
+ default # https://bugs.gentoo.org/789582
+ java-pkg-simple_src_install
+}
diff --git a/dev-java/lmax-disruptor/metadata.xml b/dev-java/lmax-disruptor/metadata.xml
new file mode 100644
index 000000000000..bc7984dba201
--- /dev/null
+++ b/dev-java/lmax-disruptor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">LMAX-Exchange/disruptor</remote-id>
+ <bugs-to>https://github.com/LMAX-Exchange/disruptor/issues</bugs-to>
+ </upstream>
+</pkgmetadata>