summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-12-03 18:19:39 +0100
committerAndreas K. Huettel (dilfridge) <dilfridge@gentoo.org>2015-12-03 18:20:09 +0100
commitf939882e96e9020835ec6d883a5a8e4e4e1ad971 (patch)
treea74630f9dd73061476a8cb2e74a52cb40d31b433
parentdev-libs/openssl: version bump to 0.9.8zh & 1.0.2e #567476 (diff)
downloadgentoo-f939882e96e9020835ec6d883a5a8e4e4e1ad971.tar.gz
gentoo-f939882e96e9020835ec6d883a5a8e4e4e1ad971.tar.bz2
gentoo-f939882e96e9020835ec6d883a5a8e4e4e1ad971.zip
app-shells/psh: Add compatibility patch for Perl 5.22; other QA cleanups
Package-Manager: portage-2.2.26
-rw-r--r--app-shells/psh/files/psh-1.8.1-defined-array.patch11
-rw-r--r--app-shells/psh/psh-1.8.1-r1.ebuild7
-rw-r--r--app-shells/psh/psh-1.8.1-r2.ebuild38
3 files changed, 53 insertions, 3 deletions
diff --git a/app-shells/psh/files/psh-1.8.1-defined-array.patch b/app-shells/psh/files/psh-1.8.1-defined-array.patch
new file mode 100644
index 000000000000..e25c4df8b837
--- /dev/null
+++ b/app-shells/psh/files/psh-1.8.1-defined-array.patch
@@ -0,0 +1,11 @@
+--- lib/Psh.pm 2007-07-21 16:40:44.000000000 +1200
++++ lib/Psh.pm 2015-07-18 05:30:29.840928282 +1200
+@@ -367,7 +367,7 @@
+
+ sub defined_and_nonempty
+ {
+- if (!defined(@_)) { return 0; }
++ if (!@_) { return 0; }
+ if (scalar(@_) == 0) { return 0; }
+
+ if (scalar(@_) == 1) {
diff --git a/app-shells/psh/psh-1.8.1-r1.ebuild b/app-shells/psh/psh-1.8.1-r1.ebuild
index 8731c5961667..79a11d7bbd27 100644
--- a/app-shells/psh/psh-1.8.1-r1.ebuild
+++ b/app-shells/psh/psh-1.8.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -16,8 +16,9 @@ KEYWORDS="amd64 ppc x86"
# Package warrants USE doc & examples
IUSE="readline"
-DEPEND=""
-RDEPEND="readline? (
+DEPEND="<dev-lang/perl-5.22.0"
+RDEPEND="<dev-lang/perl-5.22.0
+ readline? (
dev-perl/Term-ReadLine-Gnu
dev-perl/TermReadKey )"
diff --git a/app-shells/psh/psh-1.8.1-r2.ebuild b/app-shells/psh/psh-1.8.1-r2.ebuild
new file mode 100644
index 000000000000..5a4e07a4371a
--- /dev/null
+++ b/app-shells/psh/psh-1.8.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+HOMEPAGE="http://www.focusresearch.com/gregor/sw/psh/"
+SRC_URI="http://www.focusresearch.com/gregor/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+# Package warrants USE doc & examples
+IUSE="readline"
+
+RDEPEND="
+ readline? (
+ dev-perl/Term-ReadLine-Gnu
+ dev-perl/TermReadKey
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+SRC_TEST="do parallel"
+myinst="SITEPREFIX=${D}/usr"
+
+PATCHES=(
+ "${FILESDIR}/${P}-defined-array.patch"
+)
+
+src_install() {
+ perl-module_src_install
+ dodoc examples/complete-examples doc/*
+}