summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 16:17:06 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 16:17:06 +0100
commitf93e5c7f35ab1223383bdc90da7d2daa1e53b87b (patch)
tree4800fba18817b8ba299344a985b72c6ff406a1a5
parentdev-embedded/libftdi: Disable static libs in 1.5 and 9999 (diff)
downloadgentoo-f93e5c7f.tar.gz
gentoo-f93e5c7f.tar.bz2
gentoo-f93e5c7f.zip
dev-libs/shhopt: Disable static-libs
Closes: https://bugs.gentoo.org/723180 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/shhopt/files/shhopt-1.1.7-build.patch60
-rw-r--r--dev-libs/shhopt/shhopt-1.1.7-r3.ebuild3
2 files changed, 24 insertions, 39 deletions
diff --git a/dev-libs/shhopt/files/shhopt-1.1.7-build.patch b/dev-libs/shhopt/files/shhopt-1.1.7-build.patch
index 3405511e2238..954011994bc9 100644
--- a/dev-libs/shhopt/files/shhopt-1.1.7-build.patch
+++ b/dev-libs/shhopt/files/shhopt-1.1.7-build.patch
@@ -1,12 +1,12 @@
--- a/Makefile
+++ b/Makefile
-@@ -5,20 +5,15 @@
+@@ -5,17 +5,11 @@
VERPAT = 7
VERSION = $(VERMAJ).$(VERMIN).$(VERPAT)
-# Define SHARED as 1 for Linux shared ELF library
-#SHARED = 1
--
+
-ifeq ($(SHARED),1)
LIBTARGET = lib$(DIST).so.$(VERSION)
LIBTARGETSO = lib$(DIST).so
@@ -15,69 +15,55 @@
-else
-LIBTARGET = lib$(DIST).a
-endif
-+
-+LIBTARGETA = lib$(DIST).a
LIBHEAD = $(DIST).h
--TARGETS = $(LIBTARGET)
-+TARGETS = $(LIBTARGET) $(LIBTARGETA)
-
- INSTBASEDIR = /usr/local
- INSTLIBDIR = $(INSTBASEDIR)/lib
-@@ -27,12 +22,12 @@
+ TARGETS = $(LIBTARGET)
+@@ -27,12 +21,9 @@
INSTALLPROG = install -m 755
MKDIRP = install -d -m 755
-CC = gcc
-OPTIM = -O2
-
--INCDIR = -I.
--
+ INCDIR = -I.
+
-CCOPT = -s -Wall $(OPTIM) $(INCDIR)
-+CC ?= gcc
-+AR ?= ar
-+ARFLAGS ?= rc
-+RANLIB ?= ranlib
-+CPPFLAGS += -I.
-+CFLAGS += -Wall
++CCOPT = -Wall $(INCDIR)
# Object files to store in the library
LIBOBJS = shhopt.o
-@@ -43,21 +38,19 @@
- # don't worry if you get ranlib not found errors. This probably means
+@@ -44,12 +35,7 @@
# that your ar does an implicit ranlib and you do not need to run ranlib
# separately. This error is harmless.
--$(LIBTARGET): $(LIBOBJS)
+ $(LIBTARGET): $(LIBOBJS)
-ifeq ($(SHARED),1)
- $(CC) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
-else
- ar rc $(LIBTARGET) $(LIBOBJS)
- ranlib $(LIBTARGET) || true
-endif
-+$(LIBTARGET): $(LIBOBJS:.o=.lo)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $@ $^
-+$(LIBTARGETA): $(LIBOBJS)
-+ $(AR) $(ARFLAGS) $@ $^
-+ $(RANLIB) $@
++ $(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIBTARGETSOMAJ) -o $(LIBTARGET) $(LIBOBJS)
# Note that you may need GNU's -liberty if your libc lacks strtoul
example: $(LIBTARGET) example.o
- $(CC) -o example example.c \
+@@ -57,7 +43,7 @@
-L. -I. -L$(INSTLIBDIR) -I$(INSTINCDIR) -lshhopt
--.c.o:
+ .c.o:
- $(CC) $(CCSHRD) -o $@ -c $(CCOPT) $<
-+%.lo: %.c
-+ $(COMPILE.c) $(CCSHRD) $^ -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(CCSHRD) -o $@ -c $(CCOPT) $<
depend dep:
$(CC) $(INCDIR) -MM *.c >depend
-@@ -73,7 +66,7 @@
- endif
+@@ -66,11 +52,9 @@
+ $(MKDIRP) $(INSTLIBDIR) $(INSTINCDIR)
+ $(INSTALL) $(LIBTARGET) $(INSTLIBDIR)
+ $(INSTALL) $(LIBHEAD) $(INSTINCDIR)
+-ifeq ($(SHARED),1)
+ ln -sf $(LIBTARGET) $(INSTLIBDIR)/$(LIBTARGETSOMAJ)
+ ln -sf $(LIBTARGETSOMAJ) $(INSTLIBDIR)/$(LIBTARGETSO)
+ echo "Now run ldconfig if necessary."
+-endif
clean:
-- rm -f *.o core *~ depend
-+ rm -f *.o *.lo *.so* *.a core *~ depend
-
- chmod:
- chmod a+r *
+ rm -f *.o core *~ depend
diff --git a/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild b/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
index 1d63a8b89ea7..3710e4d865d3 100644
--- a/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
+++ b/dev-libs/shhopt/shhopt-1.1.7-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,6 @@ src_compile() {
}
src_install() {
- dolib.a libshhopt.a
ln -s libshhopt.so.${PV} libshhopt.so || die
ln -s libshhopt.so.${PV} libshhopt.so.${PV:0:1} || die
dolib.so libshhopt.so*