summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-20 15:54:50 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-20 15:55:31 +1200
commitf95d4be1a123a5bc271e83b99a0567ec261ec767 (patch)
treedf54acff78cbe7324ac2944ebdf76abdcbb92450
parentapp-admin/keepassxc: Bump to version 2.6.1 (diff)
downloadgentoo-f95d4be1.tar.gz
gentoo-f95d4be1.tar.bz2
gentoo-f95d4be1.zip
dev-perl/ExtUtils-F77: Bump to version 1.240.0
- EAPI7 - Remove unused/empty variable assignments - Add bodge in src_test to allow tests to pass w/ USE="-native-symlinks" in {binutils,gcc}-config, but the code is still subject to runtime problems unless consuming code also performs the same bodge. ( https://github.com/PDLPorters/extutils-f77/issues/10 ) Upstream: - Use Text::ParseWords instead of naive split - Adjust Generic GNU compiler search order - Simplify some gfortran handling - Use File::Which instead of hand-writing the equivalent - Fix library order of -lgfortran and -lquadmath Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/ExtUtils-F77/ExtUtils-F77-1.240.0.ebuild30
-rw-r--r--dev-perl/ExtUtils-F77/Manifest1
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-F77/ExtUtils-F77-1.240.0.ebuild b/dev-perl/ExtUtils-F77/ExtUtils-F77-1.240.0.ebuild
new file mode 100644
index 000000000000..bdf30379cfdf
--- /dev/null
+++ b/dev-perl/ExtUtils-F77/ExtUtils-F77-1.240.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KGB
+DIST_VERSION=1.24
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Facilitate use of FORTRAN from Perl/XS code"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-perl/File-Which
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Text-ParseWords
+ virtual/fortran
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ # https://github.com/PDLPorters/extutils-f77/issues/10
+ tc-export F77
+ mkdir -p "${T}/bin" || die "Can't make ${T}/bin"
+ ln -vs "$(type -p "${F77}")" "${T}/bin/gfortran" || die "Can't make gfortran symlink"
+ PATH="${T}/bin:$PATH" perl-module_src_test
+}
diff --git a/dev-perl/ExtUtils-F77/Manifest b/dev-perl/ExtUtils-F77/Manifest
index ad8912bcd8f4..39c5d7828bd3 100644
--- a/dev-perl/ExtUtils-F77/Manifest
+++ b/dev-perl/ExtUtils-F77/Manifest
@@ -1 +1,2 @@
DIST ExtUtils-F77-1.20.tar.gz 12201 BLAKE2B 6adee5bb3cda1b37d230ca408384161777a4aee117f7acd36a2cc125f1b64ce06b3c86557e6dfaa7bb2b159c814694f2d79c3d2c2da8a6a67cb36358d5a7c89d SHA512 0d7cf351d84676d3dea2ec781b1e230ab4a737d34de4c15c5045603ac6e6e411b5d9b235e68bb9ba0552cc4de0ea67c8355c160840b3205429802ea1569f0400
+DIST ExtUtils-F77-1.24.tar.gz 12572 BLAKE2B 86f8099cfdbe8acdfc2db895a9114c866fbf6e23d647f32d866c95efe2aa8419be057e7318e01bf82037dc93cbd18153758f13d7548395c603451176775b4867 SHA512 83ffa66e61fd5dd30cbe3e62d93374f5e1bc5a5eef180e87a6b90a62198a1a8e69d5e1683ae48f2e400304824442b4d78bd2eacdb3822ba8df5c9da1031880fe