summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-07 14:04:14 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-07 14:05:02 -0400
commitf96357cd60b47e290acf6e0fa0cad0e98ee1d323 (patch)
treec8705986c70c56144d5d8bda1114c50494e31df1
parentdev-lang/go: 1.12.5 and 1.11.10 bump (diff)
downloadgentoo-f96357cd.tar.gz
gentoo-f96357cd.tar.bz2
gentoo-f96357cd.zip
dev-libs/libutf8proc: use proper toolchain during tests
Bug: https://bugs.gentoo.org/685266 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild
index 3d5231b82df9..eae095d0a26d 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild
@@ -26,12 +26,16 @@ PATCHES=(
"${FILESDIR}/${PN}-2.3.0-tests-nofetch.patch"
)
+_emake() {
+ emake CC=$(tc-getCC) AR=$(tc-getAR) $@
+}
+
src_compile() {
- emake CC=$(tc-getCC) AR=$(tc-getAR)
+ _emake
}
src_install() {
- emake DESTDIR="${D}" \
+ _emake DESTDIR="${D}" \
prefix="${EPREFIX}/usr" \
libdir="${EPREFIX}/usr/$(get_libdir)" \
install
@@ -43,3 +47,7 @@ src_install() {
dodir /usr/include/libutf8proc
dosym ../utf8proc.h /usr/include/libutf8proc/utf8proc.h
}
+
+src_test() {
+ _emake check
+}