summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-03-02 23:23:05 -0600
committerJohn Helmert III <ajak@gentoo.org>2022-03-02 23:23:34 -0600
commitf96824b97f7f27ed91e880df1b779a625460de28 (patch)
tree7b92a3a326266e438bff5176639c08f7c923da5e
parentsci-mathematics/metamath-databases: new package; add 20220303 (2022.03.03 sna... (diff)
downloadgentoo-f96824b9.tar.gz
gentoo-f96824b9.tar.bz2
gentoo-f96824b9.zip
x11-misc/polybar: respect LDFLAGS
Closes: https://bugs.gentoo.org/832357 Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--x11-misc/polybar/polybar-3.6.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11-misc/polybar/polybar-3.6.0.ebuild b/x11-misc/polybar/polybar-3.6.0.ebuild
index 22e5d89b9188..b7195a5207fc 100644
--- a/x11-misc/polybar/polybar-3.6.0.ebuild
+++ b/x11-misc/polybar/polybar-3.6.0.ebuild
@@ -43,6 +43,11 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+src_prepare() {
+ sed -e '/set/s/cxx_linker_flags_str/CMAKE_EXE_LINKER_FLAGS_INIT/' -i cmake/cxx.cmake || die
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_ALSA="$(usex alsa)"