summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-11 10:25:03 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-04-01 21:18:28 +0200
commitf96bf8a18579e5d949389b96ed008a4fa99a9218 (patch)
treed5d80a96f1ef7fa9fdcdbf9228d72358c8756a4e
parentnet-misc/gns3-gui: remove old (diff)
downloadgentoo-f96bf8a18579e5d949389b96ed008a4fa99a9218.tar.gz
gentoo-f96bf8a18579e5d949389b96ed008a4fa99a9218.tar.bz2
gentoo-f96bf8a18579e5d949389b96ed008a4fa99a9218.zip
app-emulation/dynamips: version bump (0.2.23), EAPI8
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-emulation/dynamips/Manifest1
-rw-r--r--app-emulation/dynamips/dynamips-0.2.23.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/dynamips/Manifest b/app-emulation/dynamips/Manifest
index 4c2341a41c36..f644cb6f154c 100644
--- a/app-emulation/dynamips/Manifest
+++ b/app-emulation/dynamips/Manifest
@@ -1 +1,2 @@
DIST dynamips-0.2.21.tar.gz 833863 BLAKE2B a3162de26839a4c99fd1f147fe0a12e04f4b225b6539aa1599550c40c6a9e21deed950b47f7afbbc1cfbe2f61a351a4185a18f56c4b63c191eccc7122e2c0115 SHA512 c7251963897b65ed5696f47f03be727cea79fe2245850c86fa6b4d8718afa10002b1e39bccefe1c7f2ba86fe6b8f52fe8663ee34f72ca3d9f846522b9b9b4d29
+DIST dynamips-0.2.23.tar.gz 835736 BLAKE2B 5ea57ffbcd289a3982d873dace5bda8941209d7a0f2e36bc0cc4266c59e266f8277a215580487fb70a505eb133672247aa76d7e41124516eb67e40b999bcd67c SHA512 b68af39cd66f10555d860437f55e63887aefdb5a949bacacf3a308cc0c4eaaab3bb9a496c5ac32fd19d3920bada807bff2af8eb66b01d8d735419fec5d134746
diff --git a/app-emulation/dynamips/dynamips-0.2.23.ebuild b/app-emulation/dynamips/dynamips-0.2.23.ebuild
new file mode 100644
index 000000000000..1a0741cc4406
--- /dev/null
+++ b/app-emulation/dynamips/dynamips-0.2.23.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Cisco 7200/3600 Simulator"
+HOMEPAGE="https://github.com/GNS3/dynamips"
+SRC_URI="https://github.com/GNS3/dynamips/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/elfutils
+ net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README.md README.hypervisor RELEASE-NOTES )
+
+PATCHES=( "${FILESDIR}/${PN}-0.2.18-docs.patch" )
+
+src_prepare() {
+ # comment out DYNAMIPS_FLAGS to respect CFLAGS
+ sed -e "s:^set ( DYNAMIPS_FLAGS:#&:" -i cmake/dependencies.cmake || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DANY_COMPILER=1
+ -DENABLE_IPV6=yes
+ )
+ cmake_src_configure
+}