summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-31 08:57:20 +0100
committerSam James <sam@gentoo.org>2022-07-31 09:25:23 +0100
commitf97a8292e83be185dbf9d0efdda56729f23bc80f (patch)
treec36df4ab9d34f9e2e1ec320d4387aee3481f63db
parentsci-chemistry/pymol: add github upstream metadata (diff)
downloadgentoo-f97a8292.tar.gz
gentoo-f97a8292.tar.bz2
gentoo-f97a8292.zip
media-sound/gpodder: add 3.11.0
Closes: https://bugs.gentoo.org/862480 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/gpodder/Manifest1
-rw-r--r--media-sound/gpodder/gpodder-3.11.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-sound/gpodder/Manifest b/media-sound/gpodder/Manifest
index de0874b81b5b..39dfc8eab3a5 100644
--- a/media-sound/gpodder/Manifest
+++ b/media-sound/gpodder/Manifest
@@ -1 +1,2 @@
DIST gpodder-3.10.21.tar.gz 1105520 BLAKE2B c17905951c14a718e48d1bbded3abc41d62088bb517cda053e9fa71e3a952bb97ac57077d428cd58c3a048ae0cc18ef9385af97dcf8b460f3860674ecdb85c1c SHA512 5311a92469f605e489553e91586b788a8d07812e41c20d1ad0717c09ab6db6da22c356d5c1942293d1e27e25afe24caf3c14c15720250d8f230f2d7738206fec
+DIST gpodder-3.11.0.tar.gz 1155120 BLAKE2B b2e46a5ea5ceec7df632f888b00e9c25a0ec1c4597540228b50cb75bd4bd6acfc7566cfffe5c9d133e8ec29e1ffc2f4551e2fd289237d1b93d2e80f6b49db0c1 SHA512 90e33e04a8afcdafa0899f25714417ce61699c641ce3df93b3a3728224bdb0be5205c064e7263d1be1f4641e61932b945741e9848726b602633a94eb754fa937
diff --git a/media-sound/gpodder/gpodder-3.11.0.ebuild b/media-sound/gpodder/gpodder-3.11.0.ebuild
new file mode 100644
index 000000000000..9e17af003d11
--- /dev/null
+++ b/media-sound/gpodder/gpodder-3.11.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="A free cross-platform podcast aggregator"
+HOMEPAGE="https://gpodder.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+dbus bluetooth mtp"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
+ >=dev-python/podcastparser-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/mygpoclient-1.8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ ')
+ bluetooth? ( net-wireless/bluez )
+ mtp? ( >=media-libs/libmtp-1.0.0:= )
+ kernel_linux? ( sys-apps/iproute2 )
+"
+BDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/help2man
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/minimock[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+
+ sed -i -e 's:--cov=gpodder::' makefile || die
+}
+
+python_test() {
+ # These are pulled out from the Makefile to give us more control
+ # See bug #795165
+ # Previously, we used 'emake releasetest' in src_test
+ LC_ALL=C epytest --ignore=tests --ignore=src/gpodder/utilwin32ctypes.py --doctest-modules src/gpodder/util.py src/gpodder/jsonconfig.py \
+ -p no:localserver
+ LC_ALL=C epytest tests --ignore=src/gpodder/utilwin32ctypes.py --ignore=src/mygpoclient \
+ -p no:localserver
+}
+
+src_install() {
+ emake PYTHON="${EPYTHON}" DESTDIR="${D}" install
+
+ distutils-r1_src_install
+
+ touch "${ED}"/usr/share/gpodder/no-update-check || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "track length detection for device sync (only one package is needed)" media-video/mplayer dev-python/eyeD3
+ optfeature "for the youtube-dl extension" net-misc/youtube-dl
+ optfeature "iPod sync support" media-libs/libgpod
+}