summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-04-18 15:21:52 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-04-18 15:22:04 +0200
commitf97fd31d4f5e5961283e49fab0b829807ffe90cd (patch)
treeabb2f5cbcf3e371c1e6691f511a346b611b6e100
parentdev-python/py: Fix tests (diff)
downloadgentoo-f97fd31d4f5e5961283e49fab0b829807ffe90cd.tar.gz
gentoo-f97fd31d4f5e5961283e49fab0b829807ffe90cd.tar.bz2
gentoo-f97fd31d4f5e5961283e49fab0b829807ffe90cd.zip
dev-python/py: Bump to v1.5.3
Package-Manager: Portage-2.3.30, Repoman-2.3.9
-rw-r--r--dev-python/py/Manifest1
-rw-r--r--dev-python/py/py-1.5.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/py/Manifest b/dev-python/py/Manifest
index c774ff54a635..82c6cf32eaab 100644
--- a/dev-python/py/Manifest
+++ b/dev-python/py/Manifest
@@ -1,3 +1,4 @@
DIST py-1.4.30.tar.gz 191796 BLAKE2B 1d908f5f29788868cb7c4da49bc8a9343176030df4549a992e06245d1d56d74ddf0477048992d282aa59e6ace1ff695a7e2c2c6f00b55f185bc91d0df8b6a6dd SHA512 dd9d92f8eaf8e5fc61bfb7feb4b07df5ae1745ebf88bcbe9d62589caa9e1f7d8beae5b2d20b407520919e47391cd50cf2d5323556fa5bd90a37e120b1d394d7a
DIST py-1.4.34.tar.gz 194450 BLAKE2B 3e5733bb53d4f7eb8e6d43a5140f2ddf692d4272b564a9dd4fe8ede2cb4d0296e7c8764957bf4615f5cc4272d07997d126133dfce8ac8837f01d91bf557023d2 SHA512 2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1
DIST py-1.5.2.tar.gz 189542 BLAKE2B f0c5995121492ebca7bab9e73b7db61edf014be8e7d76822c72ded9ea19dd647dc0a83cbbcbf732c4ddae9070126cecb00958b623ca43d2219b7be8519b5b58e SHA512 ad92110d56caba2be44c6759350b05ceb882165ad0f58e6cce8361273be874b20b01856d685b142a83edff77b41bcce2911cf5797db5253b4f3e9b36e703c07d
+DIST py-1.5.3.tar.gz 202335 BLAKE2B 6a7ef206bddd641cb5e2fe04966ae93db96a7ff757fcde604f8fd2d36c4a03ce5955c2f445a866dd5cd83026ab2a9fa17feeb0da0df3d40d9746c19d865f6325 SHA512 243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96
diff --git a/dev-python/py/py-1.5.3.ebuild b/dev-python/py/py-1.5.3.ebuild
new file mode 100644
index 000000000000..fea521eca530
--- /dev/null
+++ b/dev-python/py/py-1.5.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.readthedocs.org/ https://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.2-skip-apiwarn-pytest31.patch )
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:#&:' -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # 1 failure, test_comments, under both pypy only.
+ # Also appears the home repo has no issue tracker.
+ [[ "${EPYTHON}" == pypy ]] && return
+ py.test -v -v || die "testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}