summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-28 18:32:49 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-28 18:32:49 +0100
commitf99003d30fa6c867192ca5dd7c8aa473c8e7e648 (patch)
tree2ccb38324d4c941aee1db09b9f44954275782852
parentprofiles/default/bsd/fbsd/profile.bashrc: alias gnu tools only if present. Th... (diff)
downloadgentoo-f99003d3.tar.gz
gentoo-f99003d3.tar.bz2
gentoo-f99003d3.zip
dev-python/setuptools: Version bump
Gentoo-Bug: 575894 Package-Manager: portage-2.2.27
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-20.2.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 25cc6953cebf..6bbfab42beb2 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -15,3 +15,4 @@ DIST setuptools-19.7.tar.gz 641634 SHA256 9e0783f3e6b736530a84980dce99fb0f01dafc
DIST setuptools-20.0.tar.gz 641692 SHA256 a6f7b295f399fed3de918c4bea9e2053a5fbd9e3a55a6fef7aafe9d1f474866d SHA512 c77b8f963c1c2735014f344cb3fba6ab88fc034ea32e52501a19430538db4bc6217706532ac3427f928d55b9a2321a0948f57aca5c7a01020868efc9231dd174 WHIRLPOOL 2d2a1bb7c5ea4ace4da1ddceb6f03605858be10f8c835f8aee9be896041c3c84680f6f09edc4cbcefc99a209d6b3a9ca50f2413a8e226861ceee135543e409d3
DIST setuptools-20.1.1.tar.gz 641777 SHA256 2663ce0b0e742ee27c3a06b2da14563e4f6f713eaf5509b932a31793f9dea9a3 SHA512 72da2f5a4e07c14975b3e13246264cb4b9eb52bd6da22fce0ef0f0bb8d902249067e6c23bf263cda45de92a0cdb794f454dff95e52505045e03c7a6ab28cb2ca WHIRLPOOL d2f3f0fd31f4b7d35178c14cd411dae0b011c3f9efd8a7dea4cde24bee1e462758a9662e989ddea7777b111c6162e7d035cf924517e7e6bdcab0b3277d7765e1
DIST setuptools-20.2.1.tar.gz 675776 SHA256 6d63ffee54db07e969f556dfd24d2af6aeb78e855164c667c7214b8ef9fcf0ce SHA512 74f86bbaf46e07c4ee166612dce5b5e7e5da4a77881366478c87dce76a745ad0ecbb455da3cfb31a460655e04ad5c02053e7fcfa1ca2c5a1acb0646497506060 WHIRLPOOL 299d76869c608c6cf6defba5d7a061f320cdedd94b9038bc2a43cec663a8e8d7687432e25794c382b9046f02a3d9d14d0c954ad7fd8f258ada25f37d1eaa597e
+DIST setuptools-20.2.2.tar.gz 676284 SHA256 24fcfc15364a9fe09a220f37d2dcedc849795e3de3e4b393ee988e66a9cbd85a SHA512 e74004e5755e1abd9e6efb94887c9124a36e67651e6e626424e96575cf8e84a258d48ee6fa8f0389f15de3bddcbcb0a690810dd46c358f85659ad6f20f905a2d WHIRLPOOL 3f3b7c3c916d88fb6fc53e0b348605fbaa0463abf44a164641fb8eba0050bd1513af971874b9415b1b4939b49504e4378d7142c04ba8300fb5e468cbdb35a144
diff --git a/dev-python/setuptools/setuptools-20.2.2.ebuild b/dev-python/setuptools/setuptools-20.2.2.ebuild
new file mode 100644
index 000000000000..6d462a6c8be2
--- /dev/null
+++ b/dev-python/setuptools/setuptools-20.2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+# >=dev-python/packaging-16.4[${PYTHON_USEDEP}]
+# >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+# "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+# >=dev-python/pyparsing-2.0.6[${PYTHON_USEDEP}]
+PDEPEND="
+ >=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+# rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}