summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-02 03:56:13 +0100
committerSam James <sam@gentoo.org>2024-05-02 03:56:13 +0100
commitf9921fe41bbc09926397e4a51b563723c3cd84ed (patch)
tree2e0ce69a8152610a040569a60857ce9f0f877acf
parentdev-perl/HTTP-Cookies: add 6.110.0 (diff)
downloadgentoo-f9921fe41bbc09926397e4a51b563723c3cd84ed.tar.gz
gentoo-f9921fe41bbc09926397e4a51b563723c3cd84ed.tar.bz2
gentoo-f9921fe41bbc09926397e4a51b563723c3cd84ed.zip
perl-core/Compress-Raw-Zlib: add 2.212.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.212.0.ebuild35
-rw-r--r--perl-core/Compress-Raw-Zlib/Manifest1
2 files changed, 36 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.212.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.212.0.ebuild
new file mode 100644
index 000000000000..cfd452c3a704
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.212.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMQS
+DIST_TEST=parallel
+DIST_VERSION=2.212
+inherit perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# We use the bundled version of zlib as the minimum version for the system copy
+# Check on bumps! Look in https://github.com/pmqs/Compress-Raw-Zlib/commits/master/zlib-src.
+RDEPEND=">=sys-libs/zlib-1.3.1"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ export BUILD_ZLIB=False
+ export USE_ZLIB_NG=False
+ export OLD_ZLIB=True
+ export ZLIB_INCLUDE="${ESYSROOT}"/usr/include
+ export ZLIB_LIB="${ESYSROOT}"/usr/$(get_libdir)
+ perl-module_src_configure
+}
diff --git a/perl-core/Compress-Raw-Zlib/Manifest b/perl-core/Compress-Raw-Zlib/Manifest
index 45072f09af0a..b45c4158e5ef 100644
--- a/perl-core/Compress-Raw-Zlib/Manifest
+++ b/perl-core/Compress-Raw-Zlib/Manifest
@@ -1 +1,2 @@
DIST Compress-Raw-Zlib-2.206.tar.gz 481767 BLAKE2B be4508171b24046c289d07706b1fb61d147057789a91b39799cd61bd388bcf4d02776e79237e3dc26ba12ee578d70898b615621170b73bbdd650f90d10781012 SHA512 3c722e6f363de90f6367446624090a9c482c9ed09f34b749765706da68e55e63f94608ea1d06669af567d8f8111d3311415f1f8a3daf782368c9a7bd4ff226f5
+DIST Compress-Raw-Zlib-2.212.tar.gz 551286 BLAKE2B 2b2cdf6937e662e8a9abebfed248f4b66875f668f7d63c08b4487d5b2b071dc05b506af9ae336b97085bd9572d0fbd7fc407531bb1954cccb68752a2c04e732f SHA512 75f3c7eafed7c4a3df4e8609e2e291e390663ccbd3166b860dfeb1025f5007b7a8f568face9dff2bbb4b3eab4234cbb0806f90a0c132c7d738f520d98d033a67