summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-12 04:17:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-12 04:25:25 +0200
commitf9a12a23cb7f9a2319b519c2e338083e4ceb3c9d (patch)
tree2c2df5c670ed92326102fbe30c1598429f3659bd
parentdev-python/setuptools-gettext: Bump to 0.1.14 (diff)
downloadgentoo-f9a12a23cb7f9a2319b519c2e338083e4ceb3c9d.tar.gz
gentoo-f9a12a23cb7f9a2319b519c2e338083e4ceb3c9d.tar.bz2
gentoo-f9a12a23cb7f9a2319b519c2e338083e4ceb3c9d.zip
dev-python/apprise: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.8.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index a4f7dfc1e0cf..a32f0b5c3d39 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1 +1,2 @@
DIST apprise-1.7.6.tar.gz 1656123 BLAKE2B 49720f6ba6522f3496ad5cbf5bf72340c6b21f207d11f3c3fcdd113db2e01730b64209fad1d0c7f1ed357251e567a0fe8c875b2ab8f1befdeeab9af59f5678e3 SHA512 39fdfd129d9e8bc16070a015bc9e2b4f4bf6e61e1b87ee45ec11e99e7e87dcc3896312c7ff71d0dac9532cee36709de40d6397d98b8affda069cb3a436ab8683
+DIST apprise-1.8.0.tar.gz 1651688 BLAKE2B 32458b2a4787c0366db54890b505ca86cf1abee4299d32fd49f8fc8d37b87a6123c902747f97466b061857e7f284ed78c4001e61f587f3b47e17194324217d37 SHA512 312165b1b5c05ee632b5f2631eafc4af2b318881444851966ff6893775caa303b8d8fc819de9c2f8790eb224ac849535c5e5038a2f51dc30d477a503ed48b920
diff --git a/dev-python/apprise/apprise-1.8.0.ebuild b/dev-python/apprise/apprise-1.8.0.ebuild
new file mode 100644
index 000000000000..a85837c32c40
--- /dev/null
+++ b/dev-python/apprise/apprise-1.8.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest