summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-19 19:04:36 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-09-19 19:10:37 +0200
commitf9b0d05190c200aaf04f9ebf8d946e936a468b36 (patch)
tree15b192656b00d9f35912069891456c82793ceeeb
parentdev-python/aws-xray-sdk-python: enable py3.10 (diff)
downloadgentoo-f9b0d051.tar.gz
gentoo-f9b0d051.tar.bz2
gentoo-f9b0d051.zip
net-misc/omniORB: Remove old
Bug: https://bugs.gentoo.org/787110 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
-rw-r--r--net-misc/omniORB/Manifest1
-rw-r--r--net-misc/omniORB/omniORB-4.2.2.ebuild92
2 files changed, 0 insertions, 93 deletions
diff --git a/net-misc/omniORB/Manifest b/net-misc/omniORB/Manifest
index da350bf79e2f..875a1e7dc30f 100644
--- a/net-misc/omniORB/Manifest
+++ b/net-misc/omniORB/Manifest
@@ -1,2 +1 @@
-DIST omniORB-4.2.2.tar.bz2 2673800 BLAKE2B 6afe4759cf19b69bd02d4864e305a0ebd0d11943a54c20d53987d9775f04833d5d2dbeb99e5bdcc59d56f116cfb14b9ae92399323e3980a44d9cef47a012c24f SHA512 3fe6c05d0e7f19455c4cd6702887f91b7d14cdc248008cbc456c103072a37251387877bd64d59a271c6e92703a70bbbb9713f9fa2e45d094628e42564cffd0ad
DIST omniORB-4.2.4.tar.bz2 2713397 BLAKE2B 5759b2563dca421b9a994bb13c30ce6dd98324a2357c4908130a42ce5baec357b881c22b4dff27809607ebde27e7cd65305a91aa5cbdb6d68a19df1f36524e72 SHA512 0b142b127175f16f844823e5adf5593b290528646e13a4c30f6cbd92d159d3998a81b952717039c3f0e386f79404ddd18a3de35fc45fa88383d1d9e51064d988
diff --git a/net-misc/omniORB/omniORB-4.2.2.ebuild b/net-misc/omniORB/omniORB-4.2.2.ebuild
deleted file mode 100644
index 403726b19216..000000000000
--- a/net-misc/omniORB/omniORB-4.2.2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit python-single-r1
-
-MY_P="${P/_p/-}"
-DESCRIPTION="A robust, high-performance CORBA 2 ORB"
-HOMEPAGE="http://omniorb.sourceforge.net/"
-SRC_URI="mirror://sourceforge/omniorb/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-IUSE="doc ipv6 ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- ssl? ( dev-libs/openssl:0= )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- default
-
- # The OPTC(XX)FLAGS variables aren't present in these files, but we
- # will set them when we call emake.
- sed \
- -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
- -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
- -i mk/beforeauto.mk.in mk/platforms/i586_linux_2.0*.mk || \
- die 'failed to switch CFLAGS variables in the makefile includes'
-
- # The out-of-source build is suggested by upstream.
- mkdir build || die 'failed to create build directory'
-}
-
-src_configure() {
- cd build || die 'failed to change into the build directory'
-
- ECONF_SOURCE=".." econf \
- --disable-static \
- --with-omniORB-config=/etc/omniorb/omniORB.cfg \
- --with-omniNames-logdir=/var/log/omniORB \
- --libdir="/usr/$(get_libdir)" \
- $(use_enable ipv6) \
- $(use_with ssl openssl "/usr")
-}
-
-src_compile() {
- cd build || die 'failed to change into the build directory'
- emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}"
-}
-
-src_install() {
- cd build || die 'failed to change into the build directory'
- default
-
- rm "${ED}/usr/bin/omniidlrun.py" || \
- die 'failed to remove redundant omniidlrun.py'
-
- cd "${S}" || die "failed to change into the ${S} directory"
-
- dodoc CREDITS doc/*.html ReleaseNotes.txt update.log
- dodoc -r doc/omniORB
-
- if use doc; then
- dodoc doc/*.pdf
- fi
-
- cat <<- EOF > "${T}/90omniORB"
- PATH="/usr/share/omniORB/bin/scripts"
- OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
- EOF
- doenvd "${T}/90omniORB"
- doinitd "${FILESDIR}"/omniNames
-
- cp "sample.cfg" "${T}/omniORB.cfg" || die
- cat <<- EOF >> "${T}/omniORB.cfg"
- # resolve the omniNames running on localhost
- InitRef = NameService=corbaname::localhost
- EOF
- insinto /etc/omniorb
- doins "${T}"/omniORB.cfg
-
- keepdir /var/log/omniORB
-
- python_optimize
- python_fix_shebang "${ED}"/usr/bin/omniidl
-}