summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-10-15 02:23:08 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-10-15 02:23:08 -0400
commitf9c4785a2c90f6087bb5158f98409de89f411bcf (patch)
tree0f1856c3ddbdfc7cedd05bcc195dbf300c80b0fa
parentdev-ruby/paramesan: fix install without git installed, bug 634114 (diff)
downloadgentoo-f9c4785a.tar.gz
gentoo-f9c4785a.tar.bz2
gentoo-f9c4785a.zip
sci-libs/geos: Version bump to 3.6.2
Also fixes test failure reported in bug 526516. Gentoo-Bug: 526516 Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.6.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index 89ee96294a9c..30d2b1752711 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1,3 @@
DIST geos-3.5.0.tar.bz2 1949397 SHA256 49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02 SHA512 cd9c008c19213eb90959f950b03958e6abd9c22d83e6eb5f5a9020263ad8b0045dd5c5af60417c548fc130a57756ae1ef706710086cc277498b9ba6a0a6256b7 WHIRLPOOL f7530e1dc6b99b4ad83d9a01c44b8e6256e118f7615a473d666b00549296df00ca3c86d7ab4d0ae717a3b329b3a9ecac587bc475ee51cbd7e436922860d00ab9
DIST geos-3.6.1.tar.bz2 1833434 SHA256 4a2e4e3a7a09a7cfda3211d0f4a235d9fd3176ddf64bd8db14b4ead266189fc5 SHA512 8b28e7706567375ca02ae5f5dbebf0870e8fed8ea430596a3637e5c975e72bc0f3c16c31b052f154042dd029c54130325a8d44de95c3458f5da024a97d3cfaf9 WHIRLPOOL bda0bb3b77c7c815e0be613f9af8f544fa4410029033851564bc83a912d5d7bfabaeb5d8d3dc61ebebfb482bdc64ea3cc09b395041b22cf419662beafdfec073
+DIST geos-3.6.2.tar.bz2 2030705 SHA256 045a13df84d605a866602f6020fc6cbf8bf4c42fb50de237a08926e1d7d7652a SHA512 515d8700b8a28282678e481faee355e3a43d7b70160472a63335b8d7225d9ba10437be782378f18f31a15288118126d411a2d862f01ce35d27c96f6bc0a73016 WHIRLPOOL 137061802daf29c94951ffe651e284064c66049fed02488720bb255094ab8ba8093fcf9fca568acada94714493cd9d740898ae2c4e5fe2610a9c88255e8c88f6
diff --git a/sci-libs/geos/geos-3.6.2.ebuild b/sci-libs/geos/geos-3.6.2.ebuild
new file mode 100644
index 000000000000..57fa6fac0d90
--- /dev/null
+++ b/sci-libs/geos/geos-3.6.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig:0 )
+ ruby? ( dev-lang/swig:0 )
+"
+
+PATCHES=( "${FILESDIR}"/3.4.2-solaris-isnan.patch )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C "${S}/doc" doxygen-html
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+ use python && python_optimize "${D}$(python_get_sitedir)"/geos/
+
+ find "${D}" -name '*.la' -delete || die
+}