summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2022-05-19 14:42:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-20 14:25:12 +0300
commitf9c55a242ac6e8da55f8788d4470c0f30c918a0a (patch)
tree4786d49a4c5a8e29974d2b7f177572ba1d14fca8
parentmedia-gfx/blender: Update jpeg dep (diff)
downloadgentoo-f9c55a24.tar.gz
gentoo-f9c55a24.tar.bz2
gentoo-f9c55a24.zip
media-gfx/blender: Remove option to build standalone cycles binary
After talking to upstream, it seems like this option is not meant to be use to ship any binaries. It is simply there as an example cycles project that developers can easily modify if they want to quickly code in new features and test them in cycles (without having to go through blender). Closes: https://bugs.gentoo.org/828880 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25288 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-gfx/blender/blender-2.93.9.ebuild11
-rw-r--r--media-gfx/blender/blender-3.0.1-r5.ebuild11
-rw-r--r--media-gfx/blender/blender-3.1.2.ebuild11
-rw-r--r--media-gfx/blender/blender-9999.ebuild11
4 files changed, 12 insertions, 32 deletions
diff --git a/media-gfx/blender/blender-2.93.9.ebuild b/media-gfx/blender/blender-2.93.9.ebuild
index 09756af2d9f6..3edcc6cd0ab1 100644
--- a/media-gfx/blender/blender-2.93.9.ebuild
+++ b/media-gfx/blender/blender-2.93.9.ebuild
@@ -29,7 +29,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp headless jack jemalloc jpeg2k \
man ndof nls openal opencl +oidn +openimageio +openmp +opensubdiv \
- +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile standalone test +tiff valgrind"
+ +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile test +tiff valgrind"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -40,7 +40,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
opencl? ( cycles )
openvdb? ( tbb )
osl? ( cycles )
- standalone? ( cycles )
test? ( color-management )"
# Library versions for official builds can be found in the blender source directory in:
@@ -227,8 +226,8 @@ src_configure() {
-DWITH_CYCLES_DEVICE_OPENCL=$(usex opencl)
-DWITH_CYCLES_EMBREE=$(usex embree)
-DWITH_CYCLES_OSL=$(usex osl)
- -DWITH_CYCLES_STANDALONE=$(usex standalone)
- -DWITH_CYCLES_STANDALONE_GUI=$(usex standalone)
+ -DWITH_CYCLES_STANDALONE=OFF
+ -DWITH_CYCLES_STANDALONE_GUI=OFF
-DWITH_DOC_MANPAGE=$(usex man)
-DWITH_FFTW3=$(usex fftw)
-DWITH_GMP=$(usex gmp)
@@ -308,10 +307,6 @@ src_install() {
# Pax mark blender for hardened support.
pax-mark m "${BUILD_DIR}"/bin/blender
- if use standalone; then
- dobin "${BUILD_DIR}"/bin/cycles
- fi
-
cmake_src_install
if use man; then
diff --git a/media-gfx/blender/blender-3.0.1-r5.ebuild b/media-gfx/blender/blender-3.0.1-r5.ebuild
index 38945f3726a3..9ed2565bb8b7 100644
--- a/media-gfx/blender/blender-3.0.1-r5.ebuild
+++ b/media-gfx/blender/blender-3.0.1-r5.ebuild
@@ -30,7 +30,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp headless jack jemalloc jpeg2k \
man ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile standalone test +tiff valgrind"
+ +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile test +tiff valgrind"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -40,7 +40,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
fluid? ( tbb )
openvdb? ( tbb )
osl? ( cycles )
- standalone? ( cycles )
test? ( color-management )"
# Library versions for official builds can be found in the blender source directory in:
@@ -229,8 +228,8 @@ src_configure() {
-DWITH_CYCLES_DEVICE_CUDA=$(usex cuda TRUE FALSE)
-DWITH_CYCLES_EMBREE=$(usex embree)
-DWITH_CYCLES_OSL=$(usex osl)
- -DWITH_CYCLES_STANDALONE=$(usex standalone)
- -DWITH_CYCLES_STANDALONE_GUI=$(usex standalone)
+ -DWITH_CYCLES_STANDALONE=OFF
+ -DWITH_CYCLES_STANDALONE_GUI=OFF
-DWITH_DOC_MANPAGE=$(usex man)
-DWITH_FFTW3=$(usex fftw)
-DWITH_GMP=$(usex gmp)
@@ -316,10 +315,6 @@ src_install() {
# Pax mark blender for hardened support.
pax-mark m "${BUILD_DIR}"/bin/blender
- if use standalone; then
- dobin "${BUILD_DIR}"/bin/cycles
- fi
-
cmake_src_install
if use man; then
diff --git a/media-gfx/blender/blender-3.1.2.ebuild b/media-gfx/blender/blender-3.1.2.ebuild
index 2d10adc94e81..59c402ad800b 100644
--- a/media-gfx/blender/blender-3.1.2.ebuild
+++ b/media-gfx/blender/blender-3.1.2.ebuild
@@ -28,7 +28,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp headless jack jemalloc jpeg2k \
man +nanovdb ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile standalone test +tiff valgrind"
+ +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile test +tiff valgrind"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -38,7 +38,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
fluid? ( tbb )
openvdb? ( tbb )
osl? ( cycles )
- standalone? ( cycles )
test? ( color-management )"
# Library versions for official builds can be found in the blender source directory in:
@@ -220,8 +219,8 @@ src_configure() {
-DWITH_CYCLES_DEVICE_CUDA=$(usex cuda TRUE FALSE)
-DWITH_CYCLES_EMBREE=$(usex embree)
-DWITH_CYCLES_OSL=$(usex osl)
- -DWITH_CYCLES_STANDALONE=$(usex standalone)
- -DWITH_CYCLES_STANDALONE_GUI=$(usex standalone)
+ -DWITH_CYCLES_STANDALONE=OFF
+ -DWITH_CYCLES_STANDALONE_GUI=OFF
-DWITH_DOC_MANPAGE=$(usex man)
-DWITH_FFTW3=$(usex fftw)
-DWITH_GMP=$(usex gmp)
@@ -307,10 +306,6 @@ src_install() {
# Pax mark blender for hardened support.
pax-mark m "${BUILD_DIR}"/bin/blender
- if use standalone; then
- dobin "${BUILD_DIR}"/bin/cycles
- fi
-
cmake_src_install
if use man; then
diff --git a/media-gfx/blender/blender-9999.ebuild b/media-gfx/blender/blender-9999.ebuild
index edfe76bbcf82..88c413e69eca 100644
--- a/media-gfx/blender/blender-9999.ebuild
+++ b/media-gfx/blender/blender-9999.ebuild
@@ -28,7 +28,7 @@ IUSE="+bullet +dds +fluid +openexr +tbb \
alembic collada +color-management cuda +cycles \
debug doc +embree +ffmpeg +fftw +gmp headless jack jemalloc jpeg2k \
man +nanovdb ndof nls openal +oidn +openimageio +openmp +opensubdiv \
- +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile standalone test +tiff valgrind"
+ +openvdb +osl +pdf +potrace +pugixml pulseaudio sdl +sndfile test +tiff valgrind"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -38,7 +38,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
fluid? ( tbb )
openvdb? ( tbb )
osl? ( cycles )
- standalone? ( cycles )
test? ( color-management )"
# Library versions for official builds can be found in the blender source directory in:
@@ -220,8 +219,8 @@ src_configure() {
-DWITH_CYCLES_DEVICE_CUDA=$(usex cuda TRUE FALSE)
-DWITH_CYCLES_EMBREE=$(usex embree)
-DWITH_CYCLES_OSL=$(usex osl)
- -DWITH_CYCLES_STANDALONE=$(usex standalone)
- -DWITH_CYCLES_STANDALONE_GUI=$(usex standalone)
+ -DWITH_CYCLES_STANDALONE=OFF
+ -DWITH_CYCLES_STANDALONE_GUI=OFF
-DWITH_DOC_MANPAGE=$(usex man)
-DWITH_FFTW3=$(usex fftw)
-DWITH_GMP=$(usex gmp)
@@ -307,10 +306,6 @@ src_install() {
# Pax mark blender for hardened support.
pax-mark m "${BUILD_DIR}"/bin/blender
- if use standalone; then
- dobin "${BUILD_DIR}"/bin/cycles
- fi
-
cmake_src_install
if use man; then