summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 05:11:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-01 05:56:58 +0100
commitf9d5fcd41207e1a4a4ea4974869a4523e4d12faf (patch)
treeb729325dc28e156bb5249075c744534ee7c09594
parentdev-python/botocore: Bump to 1.29.61 (diff)
downloadgentoo-f9d5fcd4.tar.gz
gentoo-f9d5fcd4.tar.bz2
gentoo-f9d5fcd4.zip
dev-python/boto3: Bump to 1.26.61
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.61.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6aa6b788eb14..bb7f94de110e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.26.57.gh.tar.gz 593947 BLAKE2B 5a30f237d992bb766b3afaced8b9e01c792c
DIST boto3-1.26.58.gh.tar.gz 594149 BLAKE2B 5bf0ec6a321826a6f7cc346e6051e6b4d99451d0222ccf9445a9f24f561dd1797333a05d44addf1bea9b2b7e18b952c5acfa9f51a5d275fc7b34c5e8c5ab4342 SHA512 16a68f232cfdfbd4c8c6368d520c5826150039f069819aaf608a2e8b03845739a8014c54ba1fb57eeba8ebe4c6ad8e3b135d2a6a4dccd9d41de98fa0b730142d
DIST boto3-1.26.59.gh.tar.gz 594565 BLAKE2B 90c5fe950da7fabc46a4c34e0a77997cfc643273f6b3c1afed6caad3415486b25a6610c8fb9d3f3450b4f3b73e45cfec5d6b1f02666dbd2608944e2db81a955b SHA512 e4dff5978e41a9f4c29ef131d7b8c1f0ec625d9fc77a8cff9ce3c6d5a00d68e75b62da34b418252ddfeedf6302332edd8a30d88401ea393d0de3add64ab5cc40
DIST boto3-1.26.60.gh.tar.gz 595047 BLAKE2B ae920d1fd17e4ceb81c512f5d2af63e4b6c09d8a5382bc50656a8ade1bd490a28bc299d7beb9b3f2b271d1001dbad7f3f1a52177d0d6a09943aea5b351a805dc SHA512 372b3e1a5265448a1f7ed11e1d66f2d33f7b35a5b66203220470eefa93eb04cbcddf2f45809ee5d1d2d369bd75ae40dbd48580b6a30a5f43d97e6b04c6211cfa
+DIST boto3-1.26.61.gh.tar.gz 596525 BLAKE2B 4d6e4548bc7f2ee57145341a107c6ebafd4fc47b13f10ddc142e974c8444365eb5242510994d9f8bb1d020b988ae08c25322d8a6e96184053ace65583c4f0375 SHA512 22f92510a959714a2128730cd618d602542a4c0f305a3560ff8b2acfb79a8bbab07d417bb10830c04d80406cfb31fa8c3765de3506ad7839efd403410c887836
diff --git a/dev-python/boto3/boto3-1.26.61.ebuild b/dev-python/boto3/boto3-1.26.61.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.61.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}