summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-09 00:26:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-09 00:26:57 +0100
commitf9d60b100e77c67a45006729332f86131d7b4e6d (patch)
tree6663b090aa33579cd2b98cdefccb2b2aade68711
parentnet-misc/megatools: add myself as a maintainer (diff)
downloadgentoo-f9d60b100e77c67a45006729332f86131d7b4e6d.tar.gz
gentoo-f9d60b100e77c67a45006729332f86131d7b4e6d.tar.bz2
gentoo-f9d60b100e77c67a45006729332f86131d7b4e6d.zip
sci-mathematics/mathlib-tools: bump to 1.1.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/mathlib-tools/Manifest1
-rw-r--r--sci-mathematics/mathlib-tools/mathlib-tools-1.1.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/mathlib-tools/Manifest b/sci-mathematics/mathlib-tools/Manifest
index 4ab66c9a9e5d..ae52335bd324 100644
--- a/sci-mathematics/mathlib-tools/Manifest
+++ b/sci-mathematics/mathlib-tools/Manifest
@@ -1 +1,2 @@
DIST mathlib-tools-1.1.0.tar.gz 32374 BLAKE2B f470927cae1dc66478efd44de6a5fd7c8df9656351ee342d14a1e75e8774383616cedf01b21ef1b92220fb03b1f1ccb326e3363dd0fec4fb5876f43c5ddb4010 SHA512 bc59d2e41c42ecc22c5768ac3adb209f0b170e2e97fe68483d8518b78a6b4fa163c1d46e4e3996c6f3e0aaa329c642fd111b3e16d850f40b6edc81c81215d03f
+DIST mathlib-tools-1.1.1.tar.gz 32456 BLAKE2B 2cb81a6072aecc8a9c298c8bd0ac2edc7f44fecd290add5254a0c35b5e16fca4cfef32727acff883366d99101f7e62ad12709e59b317e34547fa49c404600366 SHA512 17e6105d48071ab41aaa436d3fd35774227b242e6026b30ac82fd0b4f7ea8310a9bc0abe6abe5eca3e77ec62d6a48e7584222381dc7071803215cc3189ce973b
diff --git a/sci-mathematics/mathlib-tools/mathlib-tools-1.1.1.ebuild b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.1.ebuild
new file mode 100644
index 000000000000..9ecb36eac185
--- /dev/null
+++ b/sci-mathematics/mathlib-tools/mathlib-tools-1.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Development tools for Lean's mathlib"
+HOMEPAGE="https://github.com/leanprover-community/mathlib-tools"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/${PN}.git"
+else
+ SRC_URI="https://github.com/leanprover-community/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ >=dev-python/GitPython-2.1.11[${PYTHON_USEDEP}]
+ >=dev-python/toml-0.10.0[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ sci-mathematics/lean:0/3
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Remove problematic tests (mainly issues with network)
+ rm ./tests/test_functional.py || die
+
+ distutils-r1_python_prepare_all
+}