summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-08 15:58:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-08 15:59:16 +0100
commitf9d8377083127c3b03dc0d18433f6b1761ff4e27 (patch)
tree336705a00f15870b366a4d0ea67fcb0ffb08f886
parentsys-libs/glibc: Re-keyword 2.34-r10 (diff)
downloadgentoo-f9d8377083127c3b03dc0d18433f6b1761ff4e27.tar.gz
gentoo-f9d8377083127c3b03dc0d18433f6b1761ff4e27.tar.bz2
gentoo-f9d8377083127c3b03dc0d18433f6b1761ff4e27.zip
dev-ml/uutf: bump to 1.0.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-ml/uutf/Manifest1
-rw-r--r--dev-ml/uutf/uutf-1.0.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-ml/uutf/Manifest b/dev-ml/uutf/Manifest
index 89a09addc802..bb673d510ccb 100644
--- a/dev-ml/uutf/Manifest
+++ b/dev-ml/uutf/Manifest
@@ -1,2 +1,3 @@
DIST uutf-1.0.1.tbz 22215 BLAKE2B 58cbb8db94024ddaa02c213df4e5321ad33513370c6d1d54ac09f57821df8ac3b330c2659f9aeb0e78dfd15d2f50be714a5a5d6e6d3dcc3f81539c1a6c8c3771 SHA512 35cbee8c82a566f2fe4fcd549936d4c4dc67f5b71bfd3ea97ff25d7cf21cfb77cb5ee313c95ad26a2a61bb84aa48c300bbb79a1a7128c6161e9abe9c390a7d18
DIST uutf-1.0.2.tbz 22420 BLAKE2B 8391f6c3cde40db3fa86b9243d8ea8fb52409aa958d1020f302d602bf7c06c44b7d93f7a6a64a1b0964c7bb5856e15178957bba48102dbd36d8efe9581db3787 SHA512 5f2dbe78eaf73a292438d84c7185c839a7ac13cee9616a7b5006990314c6a0d42b212854cc2e89d815d3c45804f94bb40af75ecb60da7092887d8dc21e968bdd
+DIST uutf-1.0.3.tbz 23363 BLAKE2B fe35596a3c3590df38f34219ac577d34c0899c006087cb015e971002fff0d193d7fdc281d0bc3abe2fd440e7da11cc27d10b0356f9eb73e1a2c647fd0b672bf6 SHA512 50cc4486021da46fb08156e9daec0d57b4ca469b07309c508d5a9a41e9dbcf1f32dec2ed7be027326544453dcaf9c2534919395fd826dc7768efc6cc4bfcc9f8
diff --git a/dev-ml/uutf/uutf-1.0.3.ebuild b/dev-ml/uutf/uutf-1.0.3.ebuild
new file mode 100644
index 000000000000..6f553e6fb98e
--- /dev/null
+++ b/dev-ml/uutf/uutf-1.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming Unicode codec for OCaml"
+HOMEPAGE="https://erratique.ch/software/uutf"
+SRC_URI="https://erratique.ch/software/uutf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc utftrip +ocamlopt test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="utftrip? ( ocamlopt )"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/uchar:=
+ utftrip? ( dev-ml/cmdliner:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/cmdliner )"
+
+DOCS=( CHANGES.md README.md )
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ --tests "$(usex test true false)" \
+ || die
+}
+
+src_test() {
+ if use ocamlopt ; then
+ pushd _build/test || die
+ ./test.native || die
+ # Rebuild to avoid mismatches between installed files, bug #604674
+ popd || die
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ || die
+ else
+ ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
+ fi
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+
+ use ocamlopt &&
+ nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
+ ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+ use utftrip &&
+ newbin _build/test/utftrip.$(usex ocamlopt native byte) utftrip
+
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
+}