summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-19 10:46:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-19 10:49:41 +0100
commitf9ebd941a5c3fb80b10589bedf5b25415fef1db2 (patch)
tree9ebabdc0a3161b54ae944d8187f38667ad592e8c
parentdev-java/mvel: changed 2.3.0 to slot 2.3 (diff)
downloadgentoo-f9ebd941.tar.gz
gentoo-f9ebd941.tar.bz2
gentoo-f9ebd941.zip
dev-libs/capnproto: 0.9.1 version bump, cmake, EAPI-8
No revdep use of static-libs so no effort to keep it. Bug: https://bugs.gentoo.org/751754 Closes: https://bugs.gentoo.org/827845 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/capnproto/Manifest1
-rw-r--r--dev-libs/capnproto/capnproto-0.9.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/capnproto/Manifest b/dev-libs/capnproto/Manifest
index 1beec3cfb268..d4db69afc68d 100644
--- a/dev-libs/capnproto/Manifest
+++ b/dev-libs/capnproto/Manifest
@@ -1,2 +1,3 @@
DIST capnproto-0.7.0.tar.gz 1983172 BLAKE2B d88b5f8e3278f8e3aceccdc459001b99328b0440812352dcb6b54bd11e18aa7fee6d337252841c86e9c3eb1afcdbd99884c965156d6cec37e3c0996c9ec1241f SHA512 a3ea278ded6a866759c0517d16b99bd38ffea1c163ce63a3604b752d8bdaafbc38a600de94afe12db35e7f7f06e29cc94c911dc2e0ecec6fe1185452df2a2bd3
DIST capnproto-0.8.0.tar.gz 2121249 BLAKE2B 6d4ef9adb026a8ea8bc558bed1f8ce910e9c3b050ad0ac7ebd4be323cc1709a6b08956d4d2f39daee5c6485438f64695a028ea198aaae8a6c366316f10b1a64f SHA512 a3b87d47f4c160c3c72304539c3d2a6836488a50d1014c9f0eb95c112dc1e0f85b3158d26c248eff464205388ea61733c45ba10dc5441e5dd04064ba2c7970e6
+DIST capnproto-0.9.1.tar.gz 2238849 BLAKE2B f8de56c7f79b0ddad35f3e8fec7740510ca2328e4ddc633a71420901d3fc44df44d807c3965213dfc2535bbe03832c5164242d33cd0bff901d6f288fb62bab21 SHA512 bdc5960f26214139744d768ca4558b085e2d359c375a8849ca532a4c458a2daf0ee1a1f4d00745de5abf353aa1e4084a2d85e5523006f23f591f21fac2d847fd
diff --git a/dev-libs/capnproto/capnproto-0.9.1.ebuild b/dev-libs/capnproto/capnproto-0.9.1.ebuild
new file mode 100644
index 000000000000..ff77790127b8
--- /dev/null
+++ b/dev-libs/capnproto/capnproto-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="RPC/Serialization system with capabilities support"
+HOMEPAGE="https://capnproto.org"
+SRC_URI="https://github.com/sandstorm-io/capnproto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/c++
+
+LICENSE="MIT"
+SLOT="0/091"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ssl test zlib"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+ zlib? ( sys-libs/zlib:0= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_OPENSSL=$(usex ssl)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package zlib ZLIB)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}