summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-08 13:27:40 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-08 15:30:05 +0200
commitf9f6c1e764011486cd389591f609db43b6383164 (patch)
treead086838db2db6d9770bd0dfd974dc7be5f01647
parentprofiles/features/musl: mask more gvm stragglers (diff)
downloadgentoo-f9f6c1e764011486cd389591f609db43b6383164.tar.gz
gentoo-f9f6c1e764011486cd389591f609db43b6383164.tar.bz2
gentoo-f9f6c1e764011486cd389591f609db43b6383164.zip
dev-python/pythran: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pythran/Manifest1
-rw-r--r--dev-python/pythran/pythran-0.12.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 85fcad526efa..6a4843bc3deb 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1 +1,2 @@
DIST pythran-0.11.0.gh.tar.gz 3582011 BLAKE2B 532afe9edd84d2699254bcad330dc03fcda4defce73997ec9feecf1a9e0c8f4fd407a5c4ebae7e10f96463a43453137953dc3e4df010ae7fb63d540d41b79f53 SHA512 bd703148f26a0511f5a21e691e62f4e9b7bf5a92548f8ac837b2d24135917b71b052941180c9801f29c457018eb57e5f5107a509d6815d8dd8ddab1b8626b1a1
+DIST pythran-0.12.0.gh.tar.gz 3589256 BLAKE2B 5eeba4b7d73e56cc2b696098edb085e11d406485960614b50426e3df7c425ad22537ae72a2931a9ec318ab23153660da543ec1890f03379981eee10a34b82cea SHA512 8f698cb2efc8e53005a6a18b81b9119796d56e638c4634d3a9268bc8d4ac340c7ff1a26212f17210ad7200eb8a3e0f9dd20702d9d9c51f24a76dadc7d0877693
diff --git a/dev-python/pythran/pythran-0.12.0.ebuild b/dev-python/pythran/pythran-0.12.0.ebuild
new file mode 100644
index 000000000000..edec9ecace89
--- /dev/null
+++ b/dev-python/pythran/pythran-0.12.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/
+"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ !!dev-python/setuptools-declarative-requirements
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.10.0-tests-werror.patch
+)
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}