summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Strahl <c.a.strahl@gmail.com>2020-09-25 12:35:19 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-08 09:57:20 +0300
commitf9fec030f10c4232184b8f07ffb345fd9a300287 (patch)
tree5a890e19ecc56ba738813903343a783ec7328ba9
parentdev-util/clion: version bump to 2020.2.3 (diff)
downloadgentoo-f9fec030.tar.gz
gentoo-f9fec030.tar.bz2
gentoo-f9fec030.zip
dev-util/clion: remove old versions
Package-Manager: Portage-3.0.4-r1, Repoman-3.0.1 Signed-off-by: Christian Strahl <c.a.strahl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17659 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-util/clion/Manifest1
-rw-r--r--dev-util/clion/clion-2020.2.ebuild80
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-util/clion/Manifest b/dev-util/clion/Manifest
index 178145d7fc40..6da6528a11db 100644
--- a/dev-util/clion/Manifest
+++ b/dev-util/clion/Manifest
@@ -1,2 +1 @@
DIST clion-2020.2.3.tar.gz 553585955 BLAKE2B 5bfa5da56a3dc79034ff8b4f1c66107f5143a502643d5c21289e87fd2b0510e84445366e870fd5cc5c02387d3db696bf07ad848f890d3e2438335ce5e64eded5 SHA512 f7b282dbee516249175572cb3b3910d1437c9f6720fd94aaaeb148e4ceb0eeea82428b4b83af6af142dee8ba749c3baa16e71cf5e9bced7e803f8d425b9a0d2c
-DIST clion-2020.2.tar.gz 554215003 BLAKE2B 06ba16f3d2a3ebb4731e4ce40ec2ee56d3e823520d9b477a4ca7013391adb3e3c3e59b478810fa0ac9896e5277ec71642190e37be516990b0cbddd3178d2e245 SHA512 3b48a95a071919e3122e8bd8104202e07cf9cc9362df19f75003571771a134d4d5ec4520147c43b4fbd3144de8f67ddb904dbf88ef51714ec4d4882796b1272b
diff --git a/dev-util/clion/clion-2020.2.ebuild b/dev-util/clion/clion-2020.2.ebuild
deleted file mode 100644
index e0021195a585..000000000000
--- a/dev-util/clion/clion-2020.2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop eutils
-
-DESCRIPTION="A complete toolset for C and C++ development"
-HOMEPAGE="https://www.jetbrains.com/clion"
-SRC_URI="https://download.jetbrains.com/cpp/CLion-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( IDEA IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )
- Apache-1.1 Apache-2.0 BSD BSD-2 CC0-1.0 CDDL-1.1 CPL-0.5 CPL-1.0
- EPL-1.0 EPL-2.0 GPL-2 GPL-2-with-classpath-exception GPL-3 ISC JDOM
- LGPL-2.1+ LGPL-3 MIT MPL-1.0 MPL-1.1 OFL public-domain PSF-2 UoI-NCSA ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="bindist mirror splitdebug"
-IUSE="custom-jdk"
-
-# RDEPENDS may cause false positives in repoman.
-# clion requires cmake and gdb at runtime to build and debug C/C++ projects
-RDEPEND="
- dev-libs/libdbusmenu
- dev-util/cmake
- sys-devel/gdb
- !custom-jdk? ( virtual/jdk )"
-
-QA_PREBUILT="opt/${P}/*"
-
-src_prepare() {
- default
-
- local remove_me=(
- bin/gdb/linux
- bin/lldb/linux
- bin/cmake
- license/CMake*
- lib/pty4j-native/linux/ppc64le
- )
-
- use amd64 || remove_me+=( bin/fsnotifier64 lib/pty4j-native/linux/x86_64)
- use x86 || remove_me+=( bin/fsnotifier lib/pty4j-native/linux/x86)
-
- use custom-jdk || remove_me+=( jbr )
-
- rm -rv "${remove_me[@]}" || die
-}
-
-src_install() {
- local dir="/opt/${P}"
-
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}"/bin/{clion.sh,clang/linux/clang{d,-tidy}}
-
- if use amd64; then
- fperms 755 "${dir}"/bin/fsnotifier64
- fi
- if use arm; then
- fperms 755 "${dir}"/bin/fsnotifier-arm
- fi
- if use x86; then
- fperms 755 "${dir}"/bin/fsnotifier
- fi
-
- if use custom-jdk; then
- if [[ -d jbr ]]; then
- fperms 755 "${dir}"/jbr/bin/{jaotc,java,javac,jdb,jjs,jrunscript,keytool,pack200,rmid,rmiregistry,serialver,unpack200}
- fi
- fi
-
- make_wrapper "${PN}" "${dir}/bin/${PN}.sh"
- newicon "bin/${PN}.svg" "${PN}.svg"
- make_desktop_entry "${PN}" "clion" "${PN}" "Development;IDE;"
-
- # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
- dodir /usr/lib/sysctl.d/
- echo "fs.inotify.max_user_watches = 524288" > "${D}/usr/lib/sysctl.d/30-clion-inotify-watches.conf" || die
-}