summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-02 19:36:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-02 21:56:41 +0100
commitfa06dfb1e3ae46661c962b5b681fd102ed0179b1 (patch)
treee1f454303e2be962823ecf09405c7f2e859adb6f
parentsys-devel/clang-common: add baseline hardening (diff)
downloadgentoo-fa06dfb1.tar.gz
gentoo-fa06dfb1.tar.bz2
gentoo-fa06dfb1.zip
dev-python/phply: add 1.2.6
Closes: https://bugs.gentoo.org/888253 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/phply/Manifest1
-rw-r--r--dev-python/phply/phply-1.2.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/phply/Manifest b/dev-python/phply/Manifest
index d0382784c415..d8d6efae0c28 100644
--- a/dev-python/phply/Manifest
+++ b/dev-python/phply/Manifest
@@ -1 +1,2 @@
DIST phply-1.2.5.gh.tar.gz 35624 BLAKE2B 99fe9704cef570ad3055fa6c5aaaaed866d3c41c1479efbd29bb3224ae666d2ba13ccca61e6d67a8a0da4542dec79b5fdd201254e1ad638de81fa762049f4d13 SHA512 f0e4d0a6d2dfad5163fb68660602482b6de58c0dbd60d8db2f1df0622a9da3cc24e5fd309299a4a9ccf7abde081644a9a91fac8a2800520859199060f4080dc4
+DIST phply-1.2.6.gh.tar.gz 36068 BLAKE2B 766783e047b99330e5af829be875b9ee06fa70222a9c42a8792506ef0c6decc525ca90560f54d9833cdf4516fcd447f19a05d94d595a7e5056ca5d3d89bd1753 SHA512 3d7065971c6839dbe908efbfede1865183aebb0ffea1bb3b1a27c20239736894e52dc9b0a89ad6da152f1d9411dce288cf67a907d86c9838f0516236f0c19dd6
diff --git a/dev-python/phply/phply-1.2.6.ebuild b/dev-python/phply/phply-1.2.6.ebuild
new file mode 100644
index 000000000000..f16919e8474e
--- /dev/null
+++ b/dev-python/phply/phply-1.2.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Lexer and parser for PHP source implemented using PLY"
+HOMEPAGE="
+ https://github.com/viraptor/phply/
+ https://pypi.org/project/phply/"
+SRC_URI="
+ https://github.com/viraptor/phply/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # namespace? seriously?
+ sed -i -e '/namespace_packages/d' setup.py || die
+ # prevent installing tests, turn phply back into normal package
+ mv tests/__init__.py phply/ || die
+ distutils-r1_src_prepare
+}