summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2019-10-03 05:56:39 +0000
committerMike Gilbert <floppym@gentoo.org>2019-10-04 14:42:55 -0400
commitfa13d94db978ec07661ec37e8d9d0b305671a14d (patch)
treedd9a7adb57a9cdcb06e8df8dfc56ddd51b2a3734
parentapp-i18n/fcitx-configtool: Use EAPI="7". (diff)
downloadgentoo-fa13d94db978ec07661ec37e8d9d0b305671a14d.tar.gz
gentoo-fa13d94db978ec07661ec37e8d9d0b305671a14d.tar.bz2
gentoo-fa13d94db978ec07661ec37e8d9d0b305671a14d.zip
app-i18n/fcitx-hangul: Use EAPI="7".
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild18
-rw-r--r--app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild18
2 files changed, 18 insertions, 18 deletions
diff --git a/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild b/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild
index c933884fa90f..16855499c911 100644
--- a/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild
+++ b/app-i18n/fcitx-hangul/fcitx-hangul-0.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2013-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils gnome2-utils
+inherit cmake-utils xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -24,20 +24,20 @@ SLOT="4"
KEYWORDS="amd64 ppc ppc64 x86"
IUSE=""
-RDEPEND=">=app-i18n/fcitx-4.2.9:4
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
app-i18n/libhangul:=
virtual/libiconv
virtual/libintl"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
+RDEPEND="${DEPEND}"
DOCS=(AUTHORS)
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
diff --git a/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild b/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild
index a9af4dd2d47e..917d7e983d20 100644
--- a/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild
+++ b/app-i18n/fcitx-hangul/fcitx-hangul-4.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2013-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit cmake-utils gnome2-utils
+inherit cmake-utils xdg-utils
if [[ "${PV}" =~ (^|\.)9999$ ]]; then
inherit git-r3
@@ -24,20 +24,20 @@ SLOT="4"
KEYWORDS=""
IUSE=""
-RDEPEND=">=app-i18n/fcitx-4.2.9:4
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=app-i18n/fcitx-4.2.9:4
app-i18n/libhangul:=
virtual/libiconv
virtual/libintl"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
+RDEPEND="${DEPEND}"
DOCS=(AUTHORS)
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
}