summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:04:33 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-24 08:12:59 +0300
commitfa37d91bfdc7c0acc93004ead59bf6e9d52d6428 (patch)
treeaec0472b380fb290bff6c6c64107dff34492cabc
parentdev-python/responses: drop 0.13.4 (diff)
downloadgentoo-fa37d91bfdc7c0acc93004ead59bf6e9d52d6428.tar.gz
gentoo-fa37d91bfdc7c0acc93004ead59bf6e9d52d6428.tar.bz2
gentoo-fa37d91bfdc7c0acc93004ead59bf6e9d52d6428.zip
dev-python/urllib3: drop 1.26.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-1.26.6.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index ec8591d43b1c..6dc700bc75f4 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,2 +1 @@
-DIST urllib3-1.26.6.tar.gz 289927 BLAKE2B 197b0df759b27fc4906c565426e9c7b533fad56f10695ab5ae6c6c4d05d5c889dba906be526d8b8f41405f29696046b7db6e2cbb2fa16843af80e072138cc35f SHA512 19eb4b88b7a575db717db420ff79b304769d9a6d2b576a236d69719101c4d52d6b0079bd049c885e630f0dfd60471f8bb33836847e0569652cddece910ec2979
DIST urllib3-1.26.7.tar.gz 291350 BLAKE2B 5a95ea4df2e5a66ac7f3059b5453e122ae0e40531a23cb743e5a9574778a370d0cee3cb63fe6b29483b27c4a6ec498266ec5a0434db882ce0a79fb8d8400e08d SHA512 6f5a5e6dd5ff99950fcc051495e0a698153b57e20b6c83d869b54c7fece9616909bcf2fe99efc40815f8722996ad93e430bf765ce5c629b912690c286014b86f
diff --git a/dev-python/urllib3/urllib3-1.26.6.ebuild b/dev-python/urllib3/urllib3-1.26.6.ebuild
deleted file mode 100644
index 5502af18524b..000000000000
--- a/dev-python/urllib3/urllib3-1.26.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/urllib3/urllib3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{6..10})
- )
-"
-
-python_prepare_all() {
- # tests failing if 'localhost.' cannot be resolved
- sed -e 's:test_dotted_fqdn:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
- -i test/with_dummyserver/test_socketlevel.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- # please keep in sync with BDEPEND!
- has "${EPYTHON}" python3.{6..10} || continue
-
- local deselect=(
- # TODO?
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- )
-
- epytest ${deselect[@]/#/--deselect }
-}