summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-03 20:12:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-03 20:30:12 +0300
commitfa44a2f0245cfb7b09cd80e4c61c067afe332e9f (patch)
tree689a2a3b2b98188026752b481653f9fdef1fc062
parentdev-python/ubelt: add 1.2.0 (diff)
downloadgentoo-fa44a2f0.tar.gz
gentoo-fa44a2f0.tar.bz2
gentoo-fa44a2f0.zip
dev-python/yappi: add 1.3.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.3.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index 9911da7ac7bb..ec3eefb7206e 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1 +1,2 @@
DIST yappi-1.3.5.gh.tar.gz 936884 BLAKE2B a33ea0c506b3e0d05e141b01ebf4af158c6c794c0c504e52c19c00295f105cfff8a6aa8964ce07e13b87cd60164adfd1107da2c286e17dc0d779e7f9e916fbf8 SHA512 2fc243522414626ed6327b3f6b26c4001f01e288700df62cef81e73cf4077af238836b100167df3c4cfb4e0091d4de14385d349b9821759401cc3666e6fe94e9
+DIST yappi-1.3.6.gh.tar.gz 937785 BLAKE2B eb98d51f450091e66429affcc12f4329629bfc466dd8db9c5e77f5385a6b7bb551fd336825d64d94141ae41129618025a716a1b4e0718b022e67978330900bf0 SHA512 f55555042363581535eb4dfca096b1c698fb32720e5d1740d72ee7290f162ec44f0ed05936d6d85fc63f347e6be19b182550bd6e6593b65616d11d109fce8cbc
diff --git a/dev-python/yappi/yappi-1.3.6.ebuild b/dev-python/yappi/yappi-1.3.6.ebuild
new file mode 100644
index 000000000000..699a13380131
--- /dev/null
+++ b/dev-python/yappi/yappi-1.3.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="
+ https://pypi.org/project/yappi/
+ https://github.com/sumerc/yappi/
+"
+SRC_URI="
+ https://github.com/sumerc/yappi/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+)
+
+python_test() {
+ local -x PYTHONPATH=tests
+ eunittest
+}