summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-04-03 09:33:08 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-04-03 09:33:08 +0200
commitfa6b744234f1106700be269926cb1652016ced74 (patch)
tree6a228f23317891c1906d435d8d99e945601b0b92
parentdev-libs/libbpf: drop 1.0.0-r1, 1.0.1 (diff)
downloadgentoo-fa6b744234f1106700be269926cb1652016ced74.tar.gz
gentoo-fa6b744234f1106700be269926cb1652016ced74.tar.bz2
gentoo-fa6b744234f1106700be269926cb1652016ced74.zip
net-misc/frr: drop 8.4.1
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--net-misc/frr/Manifest1
-rw-r--r--net-misc/frr/frr-8.4.1.ebuild149
2 files changed, 0 insertions, 150 deletions
diff --git a/net-misc/frr/Manifest b/net-misc/frr/Manifest
index 8a218a181e80..52fa8bf498c2 100644
--- a/net-misc/frr/Manifest
+++ b/net-misc/frr/Manifest
@@ -1,2 +1 @@
-DIST frr-8.4.1.tar.gz 9886182 BLAKE2B be270f34e9ffdbf87a10c7bbd73e9f244128821f1c014060880015e4e7e06165dbc1dc3253894bda5dc1a0607a5bdbad21a70532e9019f1e06d0abd24beffff1 SHA512 69f936580d2e7838e1f15fdfa71a4fa00e7acaa93df4cdbd6129560fbcd45f3754cf5d03b4c9331bf4850477560d63d5509d185098583d19fa93d9e960e1483a
DIST frr-8.4.2.tar.gz 9893223 BLAKE2B 670fb131c2959b0ce4f3133ef38caeb7832275844b16f8582a693033f5466ad0eb98ab45ed9615e0a121ab80bf034edafe7ee816c47d767bd8a13b52f3138eac SHA512 1ee9d17ef3b85c5c10df624a6560bcacb2b5daa3d6231e457f06d9eb6e5ccf375064a46e809d851c23cb6daf7a4299d1f25be589992ef729e80f9bad41a8d7f7
diff --git a/net-misc/frr/frr-8.4.1.ebuild b/net-misc/frr/frr-8.4.1.ebuild
deleted file mode 100644
index 1edebad2d2fe..000000000000
--- a/net-misc/frr/frr-8.4.1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit autotools pam python-single-r1 systemd
-
-DESCRIPTION="The FRRouting Protocol Suite"
-HOMEPAGE="https://frrouting.org/"
-SRC_URI="https://github.com/FRRouting/frr/archive/${P}.tar.gz"
-# FRR tarballs have weird format.
-S="${WORKDIR}/frr-${P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc fpm grpc ipv6 nhrp ospfapi pam rpki snmp test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- ${PYTHON_DEPS}
- acct-user/frr
- dev-libs/json-c:0=
- >=net-libs/libyang-2.0.0
- sys-libs/libcap
- sys-libs/readline:0=
- virtual/libcrypt:=
- grpc? ( net-libs/grpc:= )
- nhrp? ( net-dns/c-ares:0= )
- pam? ( sys-libs/pam )
- rpki? ( >=net-libs/rtrlib-0.8.0[ssh] )
- snmp? ( net-analyzer/net-snmp:= )
-"
-BDEPEND="
- ~dev-util/clippy-${PV}
- sys-devel/flex
- app-alternatives/yacc
- doc? ( dev-python/sphinx )
-"
-DEPEND="
- ${COMMON_DEPEND}
- elibc_musl? ( sys-libs/queue-standalone )
- test? ( $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]') )
-"
-RDEPEND="
- ${COMMON_DEPEND}
- $(python_gen_cond_dep 'dev-python/ipaddr[${PYTHON_USEDEP}]')
- !net-misc/quagga
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.5-ipctl-forwarding.patch
- "${FILESDIR}"/${PN}-8.4.1-logrotate.patch
-)
-
-src_prepare() {
- default
-
- python_fix_shebang tools
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- --disable-static
- --with-pkg-extra-version="-gentoo"
- --enable-configfile-mask=0640
- --enable-logfile-mask=0640
- --prefix="${EPREFIX}"/usr
- --libdir="${EPREFIX}"/usr/lib/frr
- --sbindir="${EPREFIX}"/usr/lib/frr
- --libexecdir="${EPREFIX}"/usr/lib/frr
- --sysconfdir="${EPREFIX}"/etc/frr
- --localstatedir="${EPREFIX}"/run/frr
- --with-moduledir="${EPREFIX}"/usr/lib/frr/modules
- --with-clippy="${BROOT}"/usr/bin/clippy
- --enable-user=frr
- --enable-group=frr
- --enable-vty-group=frr
- --enable-multipath=64
- $(use_enable doc)
- $(use_enable fpm)
- $(use_enable grpc)
- $(use_enable ipv6 ospf6d)
- $(use_enable ipv6 ripngd)
- $(use_enable ipv6 rtadv)
- $(use_enable kernel_linux realms)
- $(use_enable nhrp nhrpd)
- $(usex ospfapi '--enable-ospfclient' '' '' '')
- $(use_enable rpki)
- $(use_enable snmp)
- )
-
- econf "${myconf[@]}"
-}
-
-src_compile() {
- default
-
- use doc && emake -C doc html
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-
- # Install user documentation if asked
- use doc && dodoc -r doc/user/_build/html
-
- # Create configuration directory with correct permissions
- keepdir /etc/frr
- fowners frr:frr /etc/frr
- fperms 775 /etc/frr
-
- # Create logs directory with the correct permissions
- keepdir /var/log/frr
- fowners frr:frr /var/log/frr
- fperms 775 /var/log/frr
-
- # Install the default configuration files
- insinto /etc/frr
- doins tools/etc/frr/vtysh.conf
- doins tools/etc/frr/frr.conf
- doins tools/etc/frr/daemons
-
- # Fix permissions/owners.
- fowners frr:frr /etc/frr/vtysh.conf
- fowners frr:frr /etc/frr/frr.conf
- fowners frr:frr /etc/frr/daemons
- fperms 640 /etc/frr/vtysh.conf
- fperms 640 /etc/frr/frr.conf
- fperms 640 /etc/frr/daemons
-
- # Install logrotate configuration
- insinto /etc/logrotate.d
- newins redhat/frr.logrotate frr
-
- # Install PAM configuration file
- use pam && newpamd "${FILESDIR}"/frr.pam frr
-
- # Install init scripts
- systemd_dounit tools/frr.service
- newinitd "${FILESDIR}"/frr-openrc-v1 frr
-
- # Conflict files, installed by net-libs/libsmi, bug #758383
- rm "${ED}"/usr/share/yang/ietf-interfaces.yang || die
-}