summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-31 07:03:58 +0100
committerSam James <sam@gentoo.org>2023-08-31 07:04:12 +0100
commitfa7525e13bb39e816ddd607891f875224327643c (patch)
tree55d242c6d521a2240d5aae3f0cfcc6eae8102244
parentdev-db/sqlite: add 3.43.0 (diff)
downloadgentoo-fa7525e13bb39e816ddd607891f875224327643c.tar.gz
gentoo-fa7525e13bb39e816ddd607891f875224327643c.tar.bz2
gentoo-fa7525e13bb39e816ddd607891f875224327643c.zip
dev-libs/libnl: add 3.8.0
Closes: https://bugs.gentoo.org/912777 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libnl/Manifest1
-rw-r--r--dev-libs/libnl/files/libnl-3.8.0-printf-non-bash.patch22
-rw-r--r--dev-libs/libnl/files/libnl-3.8.0-python-decorator-syntax.patch21
-rw-r--r--dev-libs/libnl/libnl-3.8.0.ebuild120
-rw-r--r--dev-libs/libnl/libnl-9999.ebuild17
5 files changed, 177 insertions, 4 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index da8654736030..18fd94dbe918 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -1 +1,2 @@
DIST libnl-3.7.0.tar.gz 1000913 BLAKE2B 22c418ea520416d79ee4552ab6bc5ba99239b29e074c840d31b0ec4171a0403ea9d2c1afcbf1b3428564dd371cadd99bc062ae7540e7496f970c4fb98f967e84 SHA512 80fbbc079299c90afd2a5eda62e4d4f98bf4ef23958c3ce5101f4ed4d81d783af733213bb3bab15f218555d8460bc2394898f909f4ac024fc27281faec86a041
+DIST libnl-3.8.0.tar.gz 1071113 BLAKE2B ff90d52e9b617ad8a53e4d42f43bee065b331ed919a3effc4a0f38c8e15b46f86c1eb153816499ed77dd99063500b1dc52951891034475a5bb81da1ad8004594 SHA512 a8da7e8464c5cab2807cd86f83fca53bc77f7c3bdefe43880db7be9caf5ba6bfca1b7e778b906c12fda1cf7e6f413f88cc7ad1dcc42fe8c050a8d28a6e656c02
diff --git a/dev-libs/libnl/files/libnl-3.8.0-printf-non-bash.patch b/dev-libs/libnl/files/libnl-3.8.0-printf-non-bash.patch
new file mode 100644
index 000000000000..885f8fd750f3
--- /dev/null
+++ b/dev-libs/libnl/files/libnl-3.8.0-printf-non-bash.patch
@@ -0,0 +1,22 @@
+https://github.com/thom311/libnl/pull/360
+
+From 32f84a052a4383299b9f30ad09d2a70c3b2cf2b3 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 31 Aug 2023 06:59:59 +0100
+Subject: [PATCH] Makefile.am: avoid use of non-portable echo arguments
+
+This fixes tests with a non-bash shell as /bin/sh (in this case, dash) which
+does not support `echo -e`. echo itself is portable, but not echo with any arguments.
+
+Use `printf` instead.
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1129,7 +1129,7 @@ EXTRA_DIST += \
+
+ %.build-headers-test.c: %
+ mkdir -p "$(dir $@)"
+- echo -e "#include <$$(echo "$<" | sed 's|.*\<include/netlink/|netlink/|')>\nint main(int argc, char **argv) { return 0; }" > $@
++ printf "#include <$$(echo "$<" | sed 's|.*\<include/netlink/|netlink/|')>\nint main(int argc, char **argv) { return 0; }" > $@
+
+ %.build-headers-test.o: %.build-headers-test.c
+ $(COMPILE) -Wall -Werror -Wno-error=cpp -I$(srcdir)/include -I$(builddir)/include -c -o $@ $<
diff --git a/dev-libs/libnl/files/libnl-3.8.0-python-decorator-syntax.patch b/dev-libs/libnl/files/libnl-3.8.0-python-decorator-syntax.patch
new file mode 100644
index 000000000000..d7d14962dab4
--- /dev/null
+++ b/dev-libs/libnl/files/libnl-3.8.0-python-decorator-syntax.patch
@@ -0,0 +1,21 @@
+https://github.com/thom311/libnl/commit/9aab12dff8e89b7da826c5c0826ef13c71963e28
+
+From 9aab12dff8e89b7da826c5c0826ef13c71963e28 Mon Sep 17 00:00:00 2001
+From: David Ward <david.ward@ll.mit.edu>
+Date: Tue, 29 Aug 2023 20:54:19 -0400
+Subject: [PATCH] python: Use correct decorator syntax in HTBQdisc
+
+Fixes: 87d370912ca8 ("netlink.nlattr re-implemented in more pythonic way")
+
+https://github.com/thom311/libnl/pull/359
+--- a/python/netlink/route/qdisc/htb.py
++++ b/python/netlink/route/qdisc/htb.py
+@@ -28,7 +28,7 @@ def default_class(self, value):
+ capi.rtnl_htb_set_defcls(self._qdisc._rtnl_qdisc, int(value))
+
+ @property
+- @netlink.nlattr("r2q", type=int)
++ @netlink.nlattr(type=int)
+ def r2q(self):
+ return capi.rtnl_htb_get_rate2quantum(self._qdisc._rtnl_qdisc)
+
diff --git a/dev-libs/libnl/libnl-3.8.0.ebuild b/dev-libs/libnl/libnl-3.8.0.ebuild
new file mode 100644
index 000000000000..19cb734e478a
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.8.0.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit autotools distutils-r1 multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
+
+DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="https://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/thom311/libnl"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ S="${WORKDIR}/${LIBNL_P}"
+fi
+
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+IUSE="+debug python test utils"
+RESTRICT="!test? ( test )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ python? (
+ ${DISTUTILS_DEPS}
+ dev-lang/swig
+ )
+ test? ( dev-libs/check )
+"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+MULTILIB_WRAPPED_HEADERS=(
+ # We do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/mdb.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-decorator-syntax.patch
+ "${FILESDIR}"/${PN}-3.8.0-printf-non-bash.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use python; then
+ pushd "${S}"/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+multilib_src_configure() {
+ # bug #884277
+ export YACC=yacc.bison
+
+ ECONF_SOURCE="${S}" econf \
+ $(multilib_native_use_enable utils cli) \
+ $(use_enable debug)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ pushd python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use python ; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+
+ pushd python > /dev/null || die
+
+ distutils-r1_src_install
+
+ popd > /dev/null || die
+ fi
+}
+
+multilib_src_install_all() {
+ DOCS=( ChangeLog )
+
+ einstalldocs
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libnl/libnl-9999.ebuild b/dev-libs/libnl/libnl-9999.ebuild
index 67eba8f4740d..b7e772377e97 100644
--- a/dev-libs/libnl/libnl-9999.ebuild
+++ b/dev-libs/libnl/libnl-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_OPTIONAL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..11} )
inherit autotools distutils-r1 multilib-minimal
LIBNL_P=${P/_/-}
@@ -31,18 +31,20 @@ RESTRICT="!test? ( test )"
RDEPEND="python? ( ${PYTHON_DEPS} )"
DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
sys-devel/bison
sys-devel/flex
python? (
${DISTUTILS_DEPS}
dev-lang/swig
)
- test? ( dev-libs/check )"
+ test? ( dev-libs/check )
+"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
MULTILIB_WRAPPED_HEADERS=(
- # we do not install CLI stuff for non-native
+ # We do not install CLI stuff for non-native
/usr/include/libnl3/netlink/cli/addr.h
/usr/include/libnl3/netlink/cli/class.h
/usr/include/libnl3/netlink/cli/cls.h
@@ -58,6 +60,10 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/libnl3/netlink/cli/utils.h
)
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.8.0-printf-non-bash.patch
+)
+
src_prepare() {
default
@@ -71,6 +77,9 @@ src_prepare() {
}
multilib_src_configure() {
+ # bug #884277
+ export YACC=yacc.bison
+
ECONF_SOURCE="${S}" econf \
$(multilib_native_use_enable utils cli) \
$(use_enable debug)