summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-09 15:35:04 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2017-03-09 15:35:28 +0100
commitfa81453aceb0ceef422c5ba90fd0f261c14dd8c2 (patch)
tree03a742f108e1bc830f24cb430a669a7a84f25d7d
parentsci-mathematics/geogebra: remove old (diff)
downloadgentoo-fa81453aceb0ceef422c5ba90fd0f261c14dd8c2.tar.gz
gentoo-fa81453aceb0ceef422c5ba90fd0f261c14dd8c2.tar.bz2
gentoo-fa81453aceb0ceef422c5ba90fd0f261c14dd8c2.zip
dev-libs/weston: Version bump to 1.12.0, fix cross compilation
Based on contribution by Mykyta Holubakha. Closes: https://github.com/gentoo/gentoo/pull/2816 Bug: https://bugs.gentoo.org/show_bug.cgi?id=598238 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-libs/weston/Manifest1
-rw-r--r--dev-libs/weston/weston-1.12.0.ebuild151
-rw-r--r--dev-libs/weston/weston-9999.ebuild16
3 files changed, 159 insertions, 9 deletions
diff --git a/dev-libs/weston/Manifest b/dev-libs/weston/Manifest
index 454717bb0105..069230921a58 100644
--- a/dev-libs/weston/Manifest
+++ b/dev-libs/weston/Manifest
@@ -1,2 +1,3 @@
DIST weston-1.11.0.tar.xz 1242244 SHA256 05e086e9f186a06843b9f7a5e1abf19347b1a6e4be26d7e74927abc17b6b7125 SHA512 30c43058aeca2d90d8c57ee3beb824aa42474eb2d0fa942622949b49c7771eb5d8d9c452d496a13950baabffef3c343d7386821778ae931939039fab2f782ad5 WHIRLPOOL 5e76484c1413ddc14c426c80845790e6b636bb2d827188563ca9b41f23ca4afd6cf20c8a743c0ff1b6c09d371c3e6988d0e9765333660aeb8723ddf62208b876
+DIST weston-1.12.0.tar.xz 1260892 SHA256 ac7ac2a32e3b9f50131fccded5d2326bd36b2226712d90b61999118a09af5033 SHA512 80cf7c01951cc72b32284a5a6960c2ae7a8dfffffb155cb0f94cd3585b0afa3f06bb8e2b87467d18ab95f0fd673ad9319a6e14ee5f3cec1d3b72c7c0146c927e WHIRLPOOL a809994ea312c01548280e1e5b5915fa3f0fae32ae152a0e64edd0b86db4995a97705d4ab5af5b09cfce32633ae9cdaa6f5db2afad3e0f3c5faab583d1109725
DIST weston-1.9.0.tar.xz 1238240 SHA256 9c1b03f3184fa0b0dfdf67e215048085156e1a2ca344af6613fed36794ac48cf SHA512 9bcbb5971b8a55d9e10aacf0aae868ff03750a98daee5233dcbff5698ed84e41c4b147fa1fdb1e2be916e3b1e13f259e0eec62354517d6e2a7e1d301a8522f66 WHIRLPOOL 3329a1783da2c7509fb93a64343b6b70f6d45de614a15e17d3a2a2439b440298e25c3dd4504042de38e501877cf47d909849fd6263b081c6ccc0bf8e1362287b
diff --git a/dev-libs/weston/weston-1.12.0.ebuild b/dev-libs/weston/weston-1.12.0.ebuild
new file mode 100644
index 000000000000..b63753841a87
--- /dev/null
+++ b/dev-libs/weston/weston-1.12.0.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+fi
+VIRTUALX_REQUIRED="test"
+RESTRICT="test"
+
+inherit autotools readme.gentoo-r1 toolchain-funcs virtualx $GIT_ECLASS
+
+DESCRIPTION="Wayland reference compositor"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86 ~arm-linux"
+fi
+
+LICENSE="MIT CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp +resize-optimization screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
+
+REQUIRED_USE="
+ drm? ( gles2 )
+ screen-sharing? ( rdp )
+ systemd? ( dbus )
+ test? ( X )
+ wayland-compositor? ( gles2 )
+"
+
+RDEPEND="
+ >=dev-libs/libinput-0.8.0
+ >=dev-libs/wayland-1.12.0
+ >=dev-libs/wayland-protocols-1.2
+ lcms? ( media-libs/lcms:2 )
+ media-libs/libpng:0=
+ webp? ( media-libs/libwebp:0= )
+ jpeg? ( virtual/jpeg:0= )
+ >=x11-libs/cairo-1.11.3
+ >=x11-libs/libdrm-2.4.30
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ x11-misc/xkeyboard-config
+ fbdev? (
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ colord? ( >=x11-misc/colord-0.1.27 )
+ dbus? ( sys-apps/dbus )
+ drm? (
+ media-libs/mesa[gbm]
+ >=sys-libs/mtdev-1.1.0
+ >=virtual/udev-136
+ )
+ editor? ( x11-libs/pango )
+ gles2? (
+ media-libs/mesa[gles2,wayland]
+ )
+ rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ systemd? (
+ sys-auth/pambase[systemd]
+ sys-apps/systemd[pam]
+ )
+ launch? ( sys-auth/pambase )
+ unwind? ( sys-libs/libunwind )
+ X? (
+ x11-libs/libxcb
+ x11-libs/libX11
+ )
+ xwayland? (
+ x11-base/xorg-server[wayland]
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ else
+ elibtoolize
+ fi
+}
+
+src_configure() {
+ local myconf
+ if use examples || use test; then
+ myconf="--enable-simple-clients"
+ else
+ myconf="--disable-simple-clients"
+ fi
+
+ myconf+=" --with-cairo=image --disable-simple-egl-clients"
+
+ econf \
+ $(use_enable examples demo-clients-install) \
+ $(use_enable fbdev fbdev-compositor) \
+ $(use_enable dbus) \
+ $(use_enable drm drm-compositor) \
+ $(use_enable headless headless-compositor) \
+ $(use_enable ivi ivi-shell) \
+ $(use_enable lcms) \
+ $(use_enable rdp rdp-compositor) \
+ $(use_enable wayland-compositor) \
+ $(use_enable X x11-compositor) \
+ $(use_enable launch weston-launch) \
+ $(use_enable colord) \
+ $(use_enable gles2 egl) \
+ $(use_enable unwind libunwind) \
+ $(use_enable resize-optimization) \
+ $(use_enable screen-sharing) \
+ $(use_enable suid setuid-install) \
+ $(use_enable systemd systemd-login) \
+ $(use_enable systemd systemd-notify) \
+ $(use_enable xwayland) \
+ $(use_enable xwayland xwayland-test) \
+ $(use_with jpeg) \
+ $(use_with webp) \
+ --disable-simple-dmabuf-intel-client \
+ --disable-simple-dmabuf-v4l-client \
+ ${myconf}
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ cd "${BUILD_DIR}" || die
+ virtx emake check
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 253af5431859..b63753841a87 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
@@ -27,7 +27,7 @@ fi
LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg lcms rdp +resize-optimization rpi +launch screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp +resize-optimization screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
REQUIRED_USE="
drm? ( gles2 )
@@ -39,7 +39,7 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libinput-0.8.0
- >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-1.12.0
>=dev-libs/wayland-protocols-1.2
lcms? ( media-libs/lcms:2 )
media-libs/libpng:0=
@@ -66,10 +66,6 @@ RDEPEND="
media-libs/mesa[gles2,wayland]
)
rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
- rpi? (
- >=sys-libs/mtdev-1.1.0
- >=virtual/udev-136
- )
systemd? (
sys-auth/pambase[systemd]
sys-apps/systemd[pam]
@@ -92,8 +88,11 @@ DEPEND="${RDEPEND}
"
src_prepare() {
+ default
if [[ ${PV} = 9999* ]]; then
eautoreconf
+ else
+ elibtoolize
fi
}
@@ -116,7 +115,6 @@ src_configure() {
$(use_enable ivi ivi-shell) \
$(use_enable lcms) \
$(use_enable rdp rdp-compositor) \
- $(use_enable rpi rpi-compositor) \
$(use_enable wayland-compositor) \
$(use_enable X x11-compositor) \
$(use_enable launch weston-launch) \
@@ -143,7 +141,7 @@ src_test() {
chmod 0700 "${XDG_RUNTIME_DIR}" || die
cd "${BUILD_DIR}" || die
- Xemake check
+ virtx emake check
}
src_install() {