summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-25 22:37:29 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-25 23:21:33 +0200
commitfa8efd0fe840e22903559858ba14642c90f67802 (patch)
tree7ab5066cc6e5545c582d2e17fc18fcb553529fa7
parentdev-lang/typescript: drop old 5.1.3 (diff)
downloadgentoo-fa8efd0fe840e22903559858ba14642c90f67802.tar.gz
gentoo-fa8efd0fe840e22903559858ba14642c90f67802.tar.bz2
gentoo-fa8efd0fe840e22903559858ba14642c90f67802.zip
dev-lang/typescript: bump to 5.2.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.2.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 6e72b9b778f0..3c5db5e0b3b1 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1 +1,2 @@
DIST typescript-5.1.6.tgz 7147748 BLAKE2B 3bde82e40dd4852dc85418bb0bee09dbeb70361adba9e9071a18e640c7a53e6a5517e7a4b2e068364197919d1233dda30041c675132e659bac3e3ac5008d39f0 SHA512 cda582a33459e832c4580585ad50f3d47e85557cd449f4f2e4550c5ac42553c626e493fd78ee31913211385090be141feb5cfa3bf1baba0c374a0027bef9be1c
+DIST typescript-5.2.2.tgz 7230699 BLAKE2B c7e0908ab86f80d0b4863e4ea2ade49101735ea00840407be34afb62ff14156eb00f97504640d08da0687d1aac2a3b666b2f377b68110635f92471f9c1260988 SHA512 988e16ae91ec6c221cc13f5c178159bebf3441478abec52c52f283a11f97ffb5c7407f7cc580fc607660ec036dcf61ad66dfc206ad90274b6190624c1dfa9cd7
diff --git a/dev-lang/typescript/typescript-5.2.2.ebuild b/dev-lang/typescript/typescript-5.2.2.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}