summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 10:14:31 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 10:37:46 -0400
commitfa948787faf14ce126453b4da67b888fa3861e4c (patch)
tree928b282af3275199a82040f23508764f504c3b75
parentdev-php/PEAR-Console_Getopt: new revision to clean up dependencies. (diff)
downloadgentoo-fa948787.tar.gz
gentoo-fa948787.tar.bz2
gentoo-fa948787.zip
dev-php/PEAR-Structures_Graph: new revision to clean up dependencies.
This package had a build-time dependency on dev-lang/php that was intended to be a runtime dependency; now fixed. There were also redundant dependencies on dev-php/pear and dev-php/PEAR-PEAR (which are the same, for all intents and purposes). The dev-php/pear dependency has been removed in favor of a single PDEPEND on dev-php/PEAR-PEAR. Package-Manager: portage-2.2.28
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1-r1.ebuild27
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild34
2 files changed, 27 insertions, 34 deletions
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1-r1.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..21792447cf51
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+}
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild
deleted file mode 100644
index facc50b3d798..000000000000
--- a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.1.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# BIG FAT WARNING!
-# Do not use any pear eclass here since pear itself depends on this package.
-# Using the pear eclass will thus create a circular dependency
-
-EAPI="5"
-
-MY_PN="${PN/PEAR-/}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Graph datastructure manipulation library"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE=""
-SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
-DEPEND=">=dev-lang/php-5.3:*[pcre(+)]
- >=dev-php/PEAR-PEAR-1.8.1"
-RDEPEND="${DEPEND}"
-PDEPEND="dev-php/pear"
-HOMEPAGE="http://pear.php.net/package/Structures_Graph"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- insinto /usr/share/php
- doins -r Structures
-# Currently empty except for a sudo-html file
-# dohtml -r docs/html/*
-}