summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-07-12 22:34:59 +0100
committerMarek Szuba <marecki@gentoo.org>2022-07-12 23:20:16 +0100
commitfa952569e950f51a73409409dfafc2a2abd1a6ad (patch)
tree0d2adb49c3a036c849527076c3c4799a7141dba5
parentwww-client/qutebrowser: enable py3.11 again (diff)
downloadgentoo-fa952569e950f51a73409409dfafc2a2abd1a6ad.tar.gz
gentoo-fa952569e950f51a73409409dfafc2a2abd1a6ad.tar.bz2
gentoo-fa952569e950f51a73409409dfafc2a2abd1a6ad.zip
net-misc/oidc-agent: add 4.3.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-misc/oidc-agent/Manifest1
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.3.1_install-perms.patch59
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.3.1_liblist-automagic.patch11
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-4.3.1_prompt-user-ldflags.patch11
-rw-r--r--net-misc/oidc-agent/oidc-agent-4.3.1.ebuild86
5 files changed, 168 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
index 19d96f9eb2f8..3b61e20a7a2b 100644
--- a/net-misc/oidc-agent/Manifest
+++ b/net-misc/oidc-agent/Manifest
@@ -1 +1,2 @@
DIST oidc-agent-4.2.6.tar.gz 824079 BLAKE2B f7cf810254eae00acc1b4c036fe58dda1c62b3db4d7d02a5782269485200a6a4c1d650a6cfac5f6a0e5764a1b2e19d4885eb7744c84724f927aa6d9f18f5bb55 SHA512 6f23cb13c917ce389eea3bb55e802834ff7c1bf1c421264fdcce27eb5a20b11a498d8d76c002eb92bbf3618942803ddb9937f59d19ff1aff6fe9ca07df40d0bb
+DIST oidc-agent-4.3.1.tar.gz 2124200 BLAKE2B 4108f50688fd0d2043105972a7a7fbab58a74b6a36e0d0a739be5b42a29c3b6bedb29b2273038d49b77fc3245a51f8cf998a12fee5e39096dd5e35ec72660b05 SHA512 3b598f760b1932a07bb243ce7c978a99c209ffbe5594cbb9e084c430c11c089ff0f7be113f73b165bd5f6b382d0ab30dd230c4c9fab6e210a327af20715e6d60
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.3.1_install-perms.patch b/net-misc/oidc-agent/files/oidc-agent-4.3.1_install-perms.patch
new file mode 100644
index 000000000000..940191322345
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.3.1_install-perms.patch
@@ -0,0 +1,59 @@
+--- a/Makefile
++++ b/Makefile
+@@ -644,19 +644,19 @@
+
+ ## Man pages
+ $(MAN_PATH)/man1/$(AGENT).1: $(MANDIR)/$(AGENT).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(GEN).1: $(MANDIR)/$(GEN).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(ADD).1: $(MANDIR)/$(ADD).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(CLIENT).1: $(MANDIR)/$(CLIENT).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(AGENT_SERVICE).1: $(MANDIR)/$(AGENT_SERVICE).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(MAN_PATH)/man1/$(KEYCHAIN).1: $(MANDIR)/$(KEYCHAIN).1 $(MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+ $(PROMPT_MAN_PATH)/man1/$(PROMPT).1: $(MANDIR)/$(PROMPT).1 $(PROMPT_MAN_PATH)/man1
+- @install $< $@
++ @install -m 644 $< $@
+
+ endif
+
+@@ -673,16 +673,16 @@
+ @ln -sf $(SHARED_LIB_NAME_SO) $@
+
+ $(INCLUDE_PATH)/oidc-agent/%.h: $(SRCDIR)/api/%.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/ipc_values.h: $(SRCDIR)/defines/ipc_values.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(INCLUDE_PATH)/oidc-agent/oidc_error.h: $(SRCDIR)/utils/oidc_error.h $(INCLUDE_PATH)/oidc-agent
+- @install $< $@
++ @install -m 644 $< $@
+
+ $(LIBDEV_PATH)/liboidc-agent.a: $(APILIB)/liboidc-agent.a $(LIBDEV_PATH)
+- @install $< $@
++ @install -m 644 $< $@
+
+ endif
+
+@@ -690,7 +690,7 @@
+
+ ## scheme handler
+ $(DESKTOP_APPLICATION_PATH)/oidc-gen.desktop: $(CONFDIR)/scheme_handler/oidc-gen.desktop
+- @install -D $< $@
++ @install -m 644 -D $< $@
+ @echo "Exec=x-terminal-emulator -e bash -c \"$(BIN_AFTER_INST_PATH)/bin/$(GEN) --codeExchange=%u; exec bash\"" >> $@
+
+ ## Xsession
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.3.1_liblist-automagic.patch b/net-misc/oidc-agent/files/oidc-agent-4.3.1_liblist-automagic.patch
new file mode 100644
index 000000000000..ac9ec72c84c9
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.3.1_liblist-automagic.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -80,7 +80,7 @@
+
+ # USE_CJSON_SO ?= $(shell /sbin/ldconfig -N -v $(sed 's/:/ /g' <<< $LD_LIBRARY_PATH) 2>/dev/null | grep -i libcjson >/dev/null && echo 1 || echo 0)
+ USE_CJSON_SO ?= 0
+-USE_LIST_SO ?= $(shell /sbin/ldconfig -N -v $(sed 's/:/ /g' <<< $LD_LIBRARY_PATH) 2>/dev/null | grep -i liblist >/dev/null && echo 1 || echo 0)
++USE_LIST_SO ?= 0
+ USE_ARGP_SO ?= 0
+
+ ifeq ($(USE_CJSON_SO),1)
diff --git a/net-misc/oidc-agent/files/oidc-agent-4.3.1_prompt-user-ldflags.patch b/net-misc/oidc-agent/files/oidc-agent-4.3.1_prompt-user-ldflags.patch
new file mode 100644
index 000000000000..cd1b99ee72b5
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-4.3.1_prompt-user-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -154,7 +154,7 @@
+ LINKER := $(CC)
+ LINKER_XX := $(CXX)
+ ifndef ANY_MSYS
+-PROMPT_LFLAGS = $(CPPFLAGS) $(LSODIUM)
++PROMPT_LFLAGS := $(CPPFLAGS) $(LDFLAGS) $(LSODIUM)
+ endif
+ ifdef MAC_OS
+ LFLAGS = $(LSODIUM) $(LARGP)
diff --git a/net-misc/oidc-agent/oidc-agent-4.3.1.ebuild b/net-misc/oidc-agent/oidc-agent-4.3.1.ebuild
new file mode 100644
index 000000000000..017cd56ec18a
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-4.3.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Agent and tools for managing OpenID Connect tokens on the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+SRC_URI="https://github.com/indigo-dc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+
+DEPEND="app-crypt/libsecret
+ dev-libs/libsodium:=
+ media-gfx/qrencode
+ net-libs/libmicrohttpd:=
+ net-libs/webkit-gtk:4=
+ sys-libs/libseccomp
+ elibc_musl? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-libs/check )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1_install-perms.patch
+ "${FILESDIR}"/${PN}-4.3.1_liblist-automagic.patch
+ "${FILESDIR}"/${PN}-4.3.1_prompt-user-ldflags.patch
+)
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
+}
+
+src_compile() {
+ use elibc_musl && local -x USE_ARGP_SO=1
+ emake
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}" \
+ BIN_AFTER_INST_PATH="/usr" \
+ INCLUDE_PATH="${ED}"/usr/include \
+ LIB_PATH="${ED}"/usr/$(get_libdir) \
+ install
+
+ # This file is not compatible with Gentoo and in any case, we generally
+ # let the users load such agents themselves.
+ rm -f "${ED}"/etc/X11/Xsession.d/91${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog
+ elog "You should use oidc-gen to initially generate your account configuration"
+ elog "before it can be loaded into oidc-agent using oidc-add. For details, please"
+ elog "consult the man page of oidc-gen, or full documentation at"
+ elog " https://indigo-dc.gitbooks.io/oidc-agent/"
+ elog
+ else
+ local new_major_ver old_ver
+ new_major_ver=$(ver_cut 1)
+ for old_ver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${old_ver}) != ${new_major_ver} ]]; then
+ ewarn
+ ewarn "You are upgrading from a different major version. Please restart any running instances of ${PN}"
+ ewarn "to make sure they are compatible with the updated clients."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}