summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-21 08:08:17 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-21 08:29:58 +0200
commitfa95fde45b957c5c028a857437825cd599725c5c (patch)
tree4510cce045e33a823eeb5e9b746db67c92d4d5a0
parentx11-misc/urxvt-tabbedex: stable on x86 (diff)
downloadgentoo-fa95fde4.tar.gz
gentoo-fa95fde4.tar.bz2
gentoo-fa95fde4.zip
dev-ruby/childprocess: cleanup
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/childprocess/childprocess-1.0.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ruby/childprocess/childprocess-1.0.1.ebuild b/dev-ruby/childprocess/childprocess-1.0.1.ebuild
deleted file mode 100644
index fed3e299a0fb..000000000000
--- a/dev-ruby/childprocess/childprocess-1.0.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ruby26: code not compatible
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Solution for controlling external programs running in the background"
-HOMEPAGE="https://github.com/jarib/childprocess"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
- sed -i -e 's/git ls-files/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- sed -i -e "s:'ruby':'"${RUBY}"':" spec/childprocess_spec.rb || die
-}
-
-each_ruby_test() {
- RUBYLIB=lib RSPEC_VERSION=3 ruby-ng_rspec
-}