summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 12:42:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-08 13:36:16 +0200
commitfae38a8c21d4766a901f9f659a5c3b73eb1f6f25 (patch)
treec6134d0e30e5be165d2258e529b55c5ced451e19
parentkde-apps/cervisia: 23.04.2 version bump (diff)
downloadgentoo-fae38a8c21d4766a901f9f659a5c3b73eb1f6f25.tar.gz
gentoo-fae38a8c21d4766a901f9f659a5c3b73eb1f6f25.tar.bz2
gentoo-fae38a8c21d4766a901f9f659a5c3b73eb1f6f25.zip
kde-apps/dolphin-plugins-git: 23.04.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/dolphin-plugins-git/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-git/Manifest b/kde-apps/dolphin-plugins-git/Manifest
index 2c0f565fc388..53ac6d9994d6 100644
--- a/kde-apps/dolphin-plugins-git/Manifest
+++ b/kde-apps/dolphin-plugins-git/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-22.12.3.tar.xz 272276 BLAKE2B 485ac53e070a710dbfb07aa26c915f4c2b32d5f6e67e91c3d07d9740be2c50ba4fae3c8662216423ce7e63042b663e8a59dfbfe1b490d31a2cc5445d9c3ac33c SHA512 0225fc50f88e7bd28eda74ae2bfa0c36878b9fe6b9fade6ef86a26e380cd78c8c2d1d1608796e8369f6ad545876d5d533ccfbf34b02b2be07ab8abc4bb734f7a
DIST dolphin-plugins-23.04.1.tar.xz 272580 BLAKE2B 8f1d898dd218eea4df749bff1825928fed160ed74defee154898ee57f1dc2da4ff8987438c2a49bc658544386c9ccba09a41bff6c6eaed8981baef1084e7b33e SHA512 576abc54f29f06aa2ab0d034161f159302ad33e794a8118b566e940fdea204ed3ca00e71c5dce8dfc23e876370d77e07221feaf67aea1c84ee3e089ab45a46cc
+DIST dolphin-plugins-23.04.2.tar.xz 272640 BLAKE2B 9eb16d5625e2207fc8a301ed8fe6352beedd48f063d139e275b4306a215344163aba90bd1fec3a7f63e2e1cd0692d92af46b910c55dc8fd228a9794f0d6e4a23 SHA512 daffe06e0ad07dd4d5cc93a8cbf362fd54fdf930263b669f54893cfa28d4f838f7cbd8d6f2960c534d367493349b0aa147124718538e0014088e80fb4f6feb5d
diff --git a/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.2.ebuild b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.2.ebuild
new file mode 100644
index 000000000000..1b7ccaf9b170
--- /dev/null
+++ b/kde-apps/dolphin-plugins-git/dolphin-plugins-git-23.04.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="git"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Git integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ dev-vcs/git
+"
+
+src_prepare() {
+ ecm_src_prepare
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}