summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-09 10:00:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-09 11:20:43 +0100
commitfae8779c38b7808be5aa721ff35e3021906106bc (patch)
tree9a7347b02b622a9678469cb28e713d6ea80d6084
parentdev-python/fonttools: Bump to 4.28.1 (diff)
downloadgentoo-fae8779c38b7808be5aa721ff35e3021906106bc.tar.gz
gentoo-fae8779c38b7808be5aa721ff35e3021906106bc.tar.bz2
gentoo-fae8779c38b7808be5aa721ff35e3021906106bc.zip
dev-python/nbclient: Bump to 0.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbclient/Manifest1
-rw-r--r--dev-python/nbclient/nbclient-0.5.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index d42b3b60c0bb..5c80ae4ed72a 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1 +1,2 @@
DIST nbclient-0.5.4.gh.tar.gz 69711 BLAKE2B d229cf7a20df622f87984460735a6817d8bc50243b2980b2a14ce84b4f9b97336cc9fd0d4259cfa6700279eb555debf1a0bb57d9d28d78447e6a227097b77feb SHA512 1dcee18a13f143f4a688ed1d9baaca91b1753bfabac9ea97eadfa4a96fc8cd6462f471645da586a3c5c4b03550cbf5948c7320a26a299807ae09cc823cd7ff86
+DIST nbclient-0.5.5.gh.tar.gz 72661 BLAKE2B b2be54c03c12a2cdc641e329946bae37a7b8c1c4aee8ac686c6e3350f27cf7a0a2e64653afb8acac7e373f5cbbab05feba3c1c4d7e8856974621f0d1c96005df SHA512 3066f847c175ac26ab6918b71e84a8f87bc922f624011b707f8b0a6d872c123d7979a5ffec24a933b6f98a7f83bf530926ecccb5a1c6f24bd84b3fbda07fdf48
diff --git a/dev-python/nbclient/nbclient-0.5.5.ebuild b/dev-python/nbclient/nbclient-0.5.5.ebuild
new file mode 100644
index 000000000000..28d2acc95455
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.5.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.5[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ dev-python/nest_asyncio[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest