summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-10-11 13:10:32 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-10-11 13:15:32 -0500
commitfaf2d76c7df7528bf6ee206b57a739004657eb48 (patch)
tree384d9a895ee1f542cb8da9e24e105a10b9a9f5ff
parentx11-misc/xlockmore: Old (diff)
downloadgentoo-faf2d76c.tar.gz
gentoo-faf2d76c.tar.bz2
gentoo-faf2d76c.zip
dev-util/meson: remove old
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-util/meson/Manifest1
-rw-r--r--dev-util/meson/files/0.54.2-multilib-clang.patch181
-rw-r--r--dev-util/meson/files/0.54.2-prefix-dont-strip-rpath.patch25
-rw-r--r--dev-util/meson/meson-0.54.3.ebuild98
4 files changed, 0 insertions, 305 deletions
diff --git a/dev-util/meson/Manifest b/dev-util/meson/Manifest
index 3d7d3160aa71..56d8beb192ce 100644
--- a/dev-util/meson/Manifest
+++ b/dev-util/meson/Manifest
@@ -1,2 +1 @@
-DIST meson-0.54.3.tar.gz 1690919 BLAKE2B 5d71731fb33397f470e2440d4d45f828d28d56351843a35b575f8b386f0b1c90faf654289e22ba7c2c4bf6c3be72d3dc8a2257d4a688bcbf9a1f2522394e7728 SHA512 2e62bf992bf337ae5a01f7a0fb842ea0cefcdbc81f5675235e41d8182f37df2e003b0a8a90d650c6cca4ff79898f7888474f75e5103a48d7ca14f51a024e4f2b
DIST meson-0.55.3.tar.gz 1740465 BLAKE2B 7d121f5d2bf487ae3c38be5ddccde6900134b9d0ea47868aac5625449e18a1a97ae0012849b795187221632cd3ac343097ef29b282753a1e8bd871c393d5c0e8 SHA512 afb0bb25b367e681131d920995124df4b06f6d144ae1a95ebec27be13e06fefbd95840e0287cd1d84bdbb8d9c115b589a833d847c60926f55e0f15749cf66bae
diff --git a/dev-util/meson/files/0.54.2-multilib-clang.patch b/dev-util/meson/files/0.54.2-multilib-clang.patch
deleted file mode 100644
index b3aa3693e697..000000000000
--- a/dev-util/meson/files/0.54.2-multilib-clang.patch
+++ /dev/null
@@ -1,181 +0,0 @@
-From 9dc3ca2c1c9fbb47e731551c6432df144f725261 Mon Sep 17 00:00:00 2001
-From: Yevhenii Kolesnikov <yevhenii.kolesnikov@globallogic.com>
-Date: Thu, 21 May 2020 18:58:47 +0300
-Subject: [PATCH] compilers: add fetching of define list for clang
-
-Simmilar to gcc, the list of pre-processor defines can be fetched with
-`-dM -E` option. The way cpu_family is determined on linux relies on
-this list.
-
-Fixes incorrect value of cpu_family on linux, when crosscompiling:
-
-```
-CC="clang -m32" meson ./build
-```
-
-Signed-off-by: Yevhenii Kolesnikov <yevhenii.kolesnikov@globallogic.com>
-Co-authored-by: Dylan Baker <dylan@pnwbakers.com>
----
- mesonbuild/compilers/c.py | 5 +++--
- mesonbuild/compilers/cpp.py | 5 +++--
- mesonbuild/compilers/fortran.py | 2 +-
- mesonbuild/compilers/mixins/clang.py | 9 ++++++++-
- mesonbuild/compilers/objc.py | 2 +-
- mesonbuild/compilers/objcpp.py | 2 +-
- mesonbuild/environment.py | 26 +++++++++++++++++++++++++-
- 7 files changed, 42 insertions(+), 9 deletions(-)
-
-diff --git a/mesonbuild/compilers/c.py b/mesonbuild/compilers/c.py
-index 1bc9e84998..aac99b4269 100644
---- a/mesonbuild/compilers/c.py
-+++ b/mesonbuild/compilers/c.py
-@@ -86,9 +86,10 @@ class ClangCCompiler(ClangCompiler, CCompiler):
- _C18_VERSION = '>=8.0.0'
-
- def __init__(self, exelist, version, for_machine: MachineChoice,
-- is_cross, info: 'MachineInfo', exe_wrapper=None, **kwargs):
-+ is_cross, info: 'MachineInfo', exe_wrapper=None,
-+ defines: T.Optional[T.List[str]] = None, **kwargs):
- CCompiler.__init__(self, exelist, version, for_machine, is_cross, info, exe_wrapper, **kwargs)
-- ClangCompiler.__init__(self)
-+ ClangCompiler.__init__(self, defines)
- default_warn_args = ['-Wall', '-Winvalid-pch']
- self.warn_args = {'0': [],
- '1': default_warn_args,
-diff --git a/mesonbuild/compilers/cpp.py b/mesonbuild/compilers/cpp.py
-index f4bcfa9f89..478a68c13c 100644
---- a/mesonbuild/compilers/cpp.py
-+++ b/mesonbuild/compilers/cpp.py
-@@ -155,10 +155,11 @@ def _find_best_cpp_std(self, cpp_std):
-
- class ClangCPPCompiler(ClangCompiler, CPPCompiler):
- def __init__(self, exelist, version, for_machine: MachineChoice,
-- is_cross, info: 'MachineInfo', exe_wrapper=None, **kwargs):
-+ is_cross, info: 'MachineInfo', exe_wrapper=None,
-+ defines : T.Optional[T.List[str]] = None, **kwargs):
- CPPCompiler.__init__(self, exelist, version, for_machine, is_cross,
- info, exe_wrapper, **kwargs)
-- ClangCompiler.__init__(self)
-+ ClangCompiler.__init__(self, defines)
- default_warn_args = ['-Wall', '-Winvalid-pch', '-Wnon-virtual-dtor']
- self.warn_args = {'0': [],
- '1': default_warn_args,
-diff --git a/mesonbuild/compilers/fortran.py b/mesonbuild/compilers/fortran.py
-index c155b5b4f3..af83c0e564 100644
---- a/mesonbuild/compilers/fortran.py
-+++ b/mesonbuild/compilers/fortran.py
-@@ -424,7 +424,7 @@ def __init__(self, exelist, version, for_machine: MachineChoice,
- **kwargs):
- FortranCompiler.__init__(self, exelist, version, for_machine,
- is_cross, info, exe_wrapper, **kwargs)
-- ClangCompiler.__init__(self)
-+ ClangCompiler.__init__(self, [])
- self.id = 'flang'
- default_warn_args = ['-Minform=inform']
- self.warn_args = {'0': [],
-diff --git a/mesonbuild/compilers/mixins/clang.py b/mesonbuild/compilers/mixins/clang.py
-index 1c0ee452f4..0ee10ad5d5 100644
---- a/mesonbuild/compilers/mixins/clang.py
-+++ b/mesonbuild/compilers/mixins/clang.py
-@@ -42,9 +42,10 @@
- } # type: T.Dict[str, T.List[str]]
-
- class ClangCompiler(GnuLikeCompiler):
-- def __init__(self):
-+ def __init__(self, defines: T.Optional[T.Dict[str, str]]):
- super().__init__()
- self.id = 'clang'
-+ self.defines = defines or {}
- self.base_options.append('b_colorout')
- # TODO: this really should be part of the linker base_options, but
- # linkers don't have base_options.
-@@ -56,6 +57,12 @@ def __init__(self):
- def get_colorout_args(self, colortype: str) -> T.List[str]:
- return clang_color_args[colortype][:]
-
-+ def has_builtin_define(self, define: str) -> bool:
-+ return define in self.defines
-+
-+ def get_builtin_define(self, define: str) -> T.Optional[str]:
-+ return self.defines.get(define)
-+
- def get_optimization_args(self, optimization_level: str) -> T.List[str]:
- return clang_optimization_args[optimization_level]
-
-diff --git a/mesonbuild/compilers/objc.py b/mesonbuild/compilers/objc.py
-index 52d258dcdb..d351c8826a 100644
---- a/mesonbuild/compilers/objc.py
-+++ b/mesonbuild/compilers/objc.py
-@@ -86,7 +86,7 @@ def __init__(self, exelist, version, for_machine: MachineChoice,
- **kwargs):
- ObjCCompiler.__init__(self, exelist, version, for_machine, is_cross,
- info, exe_wrapper, **kwargs)
-- ClangCompiler.__init__(self)
-+ ClangCompiler.__init__(self, [])
- default_warn_args = ['-Wall', '-Winvalid-pch']
- self.warn_args = {'0': [],
- '1': default_warn_args,
-diff --git a/mesonbuild/compilers/objcpp.py b/mesonbuild/compilers/objcpp.py
-index c8b422b35d..10555b4551 100644
---- a/mesonbuild/compilers/objcpp.py
-+++ b/mesonbuild/compilers/objcpp.py
-@@ -84,7 +84,7 @@ def __init__(self, exelist, version, for_machine: MachineChoice,
- is_cross, info: 'MachineInfo', exe_wrapper=None,
- **kwargs):
- ObjCPPCompiler.__init__(self, exelist, version, for_machine, is_cross, info, exe_wrapper, **kwargs)
-- ClangCompiler.__init__(self)
-+ ClangCompiler.__init__(self, [])
- default_warn_args = ['-Wall', '-Winvalid-pch', '-Wnon-virtual-dtor']
- self.warn_args = {'0': [],
- '1': default_warn_args,
-diff --git a/mesonbuild/environment.py b/mesonbuild/environment.py
-index 8fad6288b1..cb6ae7d514 100644
---- a/mesonbuild/environment.py
-+++ b/mesonbuild/environment.py
-@@ -726,6 +726,28 @@ def get_lcc_version_from_defines(defines):
- minor = defines.get('__LCC_MINOR__', '0')
- return dot.join((generation, major, minor))
-
-+ @staticmethod
-+ def get_clang_compiler_defines(compiler):
-+ """
-+ Get the list of Clang pre-processor defines
-+ """
-+ args = compiler + ['-E', '-dM', '-']
-+ p, output, error = Popen_safe(args, write='', stdin=subprocess.PIPE)
-+ if p.returncode != 0:
-+ raise EnvironmentException('Unable to get clang pre-processor defines:\n' + output + error)
-+ defines = {}
-+ for line in output.split('\n'):
-+ if not line:
-+ continue
-+ d, *rest = line.split(' ', 2)
-+ if d != '#define':
-+ continue
-+ if len(rest) == 1:
-+ defines[rest] = True
-+ if len(rest) == 2:
-+ defines[rest[0]] = rest[1]
-+ return defines
-+
- def _get_compilers(self, lang, for_machine):
- '''
- The list of compilers is detected in the exact same way for
-@@ -1043,6 +1065,8 @@ def sanitize(p):
- if 'clang' in out:
- linker = None
-
-+ defines = self.get_clang_compiler_defines(compiler)
-+
- # Even if the for_machine is darwin, we could be using vanilla
- # clang.
- if 'Apple' in out:
-@@ -1063,7 +1087,7 @@ def sanitize(p):
-
- return cls(
- ccache + compiler, version, for_machine, is_cross, info,
-- exe_wrap, full_version=full_version, linker=linker)
-+ exe_wrap, defines, full_version=full_version, linker=linker)
-
- if 'Intel(R) C++ Intel(R)' in err:
- version = search_version(err)
diff --git a/dev-util/meson/files/0.54.2-prefix-dont-strip-rpath.patch b/dev-util/meson/files/0.54.2-prefix-dont-strip-rpath.patch
deleted file mode 100644
index 1fe2e1ac4cc1..000000000000
--- a/dev-util/meson/files/0.54.2-prefix-dont-strip-rpath.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://bz-attachments.freebsd.org/attachment.cgi?id=204611
-https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238128
-
-Stripping RPATH on Prefix is really bad, because it means the default
-RPATH entries disappear, and any installed binaries don't work (get
-kernel traps).
-
-Extracted the minstall patch from the FreeBSD full patch.
-
---- a/mesonbuild/minstall.py
-+++ b/mesonbuild/minstall.py
-@@ -488,8 +488,11 @@
- printed_symlink_error = True
- if os.path.isfile(outname):
- try:
-- depfixer.fix_rpath(outname, install_rpath, final_path,
-- install_name_mappings, verbose=False)
-+ if install_rpath:
-+ depfixer.fix_rpath(outname, install_rpath, final_path,
-+ install_name_mappings, verbose=False)
-+ else:
-+ print("RPATH changes at install time disabled")
- except SystemExit as e:
- if isinstance(e.code, int) and e.code == 0:
- pass
diff --git a/dev-util/meson/meson-0.54.3.ebuild b/dev-util/meson/meson-0.54.3.ebuild
deleted file mode 100644
index e91ba990d3a4..000000000000
--- a/dev-util/meson/meson-0.54.3.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 2016-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS="rdepend"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mesonbuild/meson"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Open source build system"
-HOMEPAGE="https://mesonbuild.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- test? (
- dev-libs/glib:2
- dev-libs/gobject-introspection
- dev-util/ninja
- dev-vcs/git
- sys-libs/zlib[static-libs(+)]
- virtual/pkgconfig
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/0.54.2-multilib-clang.patch
-)
-
-python_prepare_all() {
- local disable_unittests=(
- # ASAN and sandbox both want control over LD_PRELOAD
- # https://bugs.gentoo.org/673016
- -e 's/test_generate_gir_with_address_sanitizer/_&/'
-
- # ASAN is unsupported on some targets
- # https://bugs.gentoo.org/692822
- -e 's/test_pch_with_address_sanitizer/_&/'
-
- # https://github.com/mesonbuild/meson/issues/7203
- -e 's/test_templates/_&/'
-
- # Broken due to python2 wrapper
- -e 's/test_python_module/_&/'
- )
-
- sed -i "${disable_unittests[@]}" run_unittests.py || die
-
- # Broken due to python2 script created by python_wrapper_setup
- rm -r "test cases/frameworks/1 boost" || die
-
- use prefix && eapply "${FILESDIR}"/0.54.2-prefix-dont-strip-rpath.patch
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- tc-export PKG_CONFIG
- if ${PKG_CONFIG} --exists Qt5Core && ! ${PKG_CONFIG} --exists Qt5Gui; then
- ewarn "Found Qt5Core but not Qt5Gui; skipping tests"
- else
- # https://bugs.gentoo.org/687792
- unset PKG_CONFIG
- distutils-r1_src_test
- fi
-}
-
-python_test() {
- (
- # test_meson_installed
- unset PYTHONDONTWRITEBYTECODE
-
- # test_cross_file_system_paths
- unset XDG_DATA_HOME
-
- ${EPYTHON} -u run_tests.py
- ) || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles
- doins -r data/syntax-highlighting/vim/{ftdetect,indent,syntax}
- insinto /usr/share/zsh/site-functions
- doins data/shell-completions/zsh/_meson
-}