summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-01 13:43:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-01 14:27:27 +0200
commitfb040924161851bb46dcbea975af4e4a8c98d6f7 (patch)
treef331c5752c41dc22eec52c1940fe7ebd959a99d3
parentdev-python/phonenumbers: Bump to 8.12.46 (diff)
downloadgentoo-fb040924.tar.gz
gentoo-fb040924.tar.bz2
gentoo-fb040924.zip
dev-python/line_profiler: Bump to 3.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-3.5.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index e445e7dd332a..fd8f3b3001ee 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1,3 +1,4 @@
DIST line_profiler-3.3.1.gh.tar.gz 56700 BLAKE2B 030c0fc742a6773ebb55a54a3c21d3d5e5d6d5d258a2c3cd2071ff93917411b65e100bfc6549d9c60d9a7c361c53b291d8b81538acaf5b83665c04129d25bc02 SHA512 8a3704a6df2abe71283cb2da23b738932c6f4b42aedcdefda0d318fd4b894d56831a855c4be4430657308530a04d1e96b0e15a60edca06621bdd5370c0bf9911
DIST line_profiler-3.4.0.gh.tar.gz 49076 BLAKE2B 1fa2d7462913b21b5c3d69be64492fd5002d10c6c454cb3129860e4156cf04fbbd839b140f229b586ff9f0b195baae435bc461c4bab1405c38da49bf348827c3 SHA512 79a6e71ec083aacbc95fab5e044a2a38119bced505e5b9720288e32103773dc64a8bbbf6c2c7913b7b5057420cb31c3943cc1dce2d7d029df82b6b59e451c357
DIST line_profiler-3.5.0.gh.tar.gz 51142 BLAKE2B 1dade129a8913f6fe42fcd646c1f8850b5a948bad476755dd54bf04815e293508d77b9160157623a6060a864722c81466690722b79a603bba9b7651ba3e7e25d SHA512 4c797bb9990e77a5ef8cb38113fe28c4925a631ca8f034f33fe2aeeeb77bf9b24cfc1fb6217ddec07b767a2dec325f388e402ca38da43790f58c644a4a147a75
+DIST line_profiler-3.5.1.gh.tar.gz 51241 BLAKE2B a3f3cceab9d34062a0b96ce772941bb945f96f7e88f59bb72d08a09fb96db3d9354ce33b0c0088065df5aeb7349c7da37d8697654d9f5130d8bd0b7997306d13 SHA512 4618e57e52b7d7d5ece034735a4ce38dd3a8af57e5b897790be4c8e1ee1757d822d7c1bb76d3c7248432c49c13708bffb9bebbbbf61442de98c5a6ec657cbd57
diff --git a/dev-python/line_profiler/line_profiler-3.5.1.ebuild b/dev-python/line_profiler/line_profiler-3.5.1.ebuild
new file mode 100644
index 000000000000..a631bb642adf
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-3.5.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+# force it to match scikit-build
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="
+ https://github.com/pyutils/line_profiler/
+"
+SRC_URI="
+ https://github.com/pyutils/line_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+# technically, the package claims to support non-scikit-build build
+# but it's clearly unmaintained and broken at the moment
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/scikit-build[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/ubelt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd tests || die
+ epytest
+}